EN ES
Start free

Accordions: known security problems

9 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 9 known security problems on this page. Each one has a fixed version. Updating to version 2.3.25 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 2.3.23)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.3.23
Fixed in
2.3.25
What to do
If your site has an affected version, update Accordions to version 2.3.25 or newer.
Official ID
CVE-2026-10862
Report title
Accordions <= 2.3.23 - Authenticated (Custom+) Stored Cross-Site Scripting via Accordion Body Field
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (up to and including 2.3.15)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.3.15
Fixed in
2.3.16
What to do
If your site has an affected version, update Accordions to version 2.3.16 or newer.
Official ID
CVE-2025-58678
Report title
Accordion <= 2.3.15 - Missing Authorization
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (up to and including 2.3.14)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.3.14
Fixed in
2.3.16
What to do
If your site has an affected version, update Accordions to version 2.3.16 or newer.
Official ID
CVE-2025-53421
Report title
Accordion <= 2.3.14 - Missing Authorization
First reported
Sources
This week

Someone with a contributor account on your site could in some setups, take over your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.3.11
Fixed in
2.3.12
What to do
If your site has an affected version, update Accordions to version 2.3.12 or newer.
Official ID
CVE-2025-32143
Report title
Accordion <= 2.3.11 - Authenticated (Contributor+) PHP Object Injection
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.99
Fixed in
2.2.100
What to do
If your site has an affected version, update Accordions to version 2.2.100 or newer.
Official ID
CVE-2024-47342
Report title
Accordion <= 2.2.99 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.96
Fixed in
2.2.97
What to do
If your site has an affected version, update Accordions to version 2.2.97 or newer.
Official ID
CVE-2024-1641
Report title
Accordion <= 2.2.96 - Missing Authorization to Authenticated(Contributor+) Post Duplication
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 2.2.40)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.40
Fixed in
2.2.43
What to do
If your site has an affected version, update Accordions to version 2.2.43 or newer.
Report title
Accordion <= 2.2.43 - Authenticated (Admin+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (before 2.2.30)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 2.2.30
Fixed in
2.2.30
What to do
If your site has an affected version, update Accordions to version 2.2.30 or newer.
Official ID
CVE-2021-24283
Report title
Accordion <= 2.2.29 - Reflected Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (before 2.2.9)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 2.2.9
Fixed in
2.2.9
What to do
If your site has an affected version, update Accordions to version 2.2.9 or newer.
Official ID
CVE-2020-13644
Report title
Accordion <= 2.2.8 - Unprotected AJAX Action to Stored/Reflected Cross-Site Scripting
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)