Admin and Site Enhancements (ASE): known security problems
12 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 12 known security problems on this page. Each one has a fixed version. Updating to version 9.0.1 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with an author account on your site could plant harmful code that runs for your visitors or admins (before 9.0.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 9.0.1
- Fixed in
- 9.0.1
- What to do
- If your site has an affected version, update Admin and Site Enhancements (ASE) to version 9.0.1 or newer.
- Official ID
- CVE-2026-19615
- Report title
- Admin and Site Enhancements (ASE) < 9.0.1 - Authenticated (Author+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 8.8.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 8.8.3
- Fixed in
- 8.8.4
- What to do
- If your site has an affected version, update Admin and Site Enhancements (ASE) to version 8.8.4 or newer.
- Official ID
- CVE-2026-12083
- Report title
- Admin and Site Enhancements <= 8.8.3 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 8.4.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 8.4.0
- Fixed in
- 8.4.1
- What to do
- If your site has an affected version, update Admin and Site Enhancements (ASE) to version 8.4.1 or newer.
- Official ID
- CVE-2026-32423
- Report title
- Admin and Site Enhancements (ASE) <= 8.4.0 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could take over your site as an admin (up to and including 7.6.2.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 7.6.2.1
- Fixed in
- 7.6.3
- What to do
- If your site has an affected version, update Admin and Site Enhancements (ASE) to version 7.6.3 or newer.
- Official ID
- CVE-2025-24648
- Report title
- Admin and Site Enhancements (ASE) <= 7.6.2.1 - Authenticated (Subscriber+) Privilege Escalation
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 8.0.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 8.0.8
- Fixed in
- 8.1.0
- What to do
- If your site has an affected version, update Admin and Site Enhancements (ASE) to version 8.1.0 or newer.
- Official ID
- CVE-2025-64255
- Report title
- Admin and Site Enhancements (ASE) <= 8.0.8 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone with an author account on your site could plant harmful code that runs for your visitors or admins (up to and including 7.9.7)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 7.9.7
- Fixed in
- 7.9.8
- What to do
- If your site has an affected version, update Admin and Site Enhancements (ASE) to version 7.9.8 or newer.
- Official ID
- CVE-2025-9487
- Report title
- Admin and Site Enhancements <= 7.9.7 - Authenticated (Author+) Stored Cross-Site Scripting via SVG
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site (up to and including 7.6.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 7.6.9
- Fixed in
- 7.6.10
- What to do
- If your site has an affected version, update Admin and Site Enhancements (ASE) to version 7.6.10 or newer.
- Official ID
- CVE-2024-13688
- Report title
- Admin and Site Enhancements (ASE) <= 7.6.9 - Password Protection Bypass
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site (up to and including 7.6.9) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 7.6.9
- Fixed in
- 7.6.10
- What to do
- If your site has an affected version, update Admin and Site Enhancements (ASE) to version 7.6.10 or newer.
- Official ID
- CVE-2024-13685
- Report title
- Admin and Site Enhancements (ASE) <= 7.6.9 - IP Spoofing to Limit Login Attempt Bypass
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could take over your site as an admin (up to and including 7.6.2.1) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 7.6.2.1
- Fixed in
- 7.6.3
- What to do
- If your site has an affected version, update Admin and Site Enhancements (ASE) to version 7.6.3 or newer.
- Official ID
- CVE-2024-43333
- Report title
- Admin and Site Enhancements (ASE) Pro <= 7.6.2.1 - Authenticated (Subscriber+) Privilege Escalation
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 7.6.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 7.6.2
- Fixed in
- 7.6.3
- What to do
- If your site has an affected version, update Admin and Site Enhancements (ASE) to version 7.6.3 or newer.
- Official ID
- CVE-2025-24649
- Report title
- Admin and Site Enhancements (ASE) <= 7.6.2 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 7.5.1
- Fixed in
- 7.5.2
- What to do
- If your site has an affected version, update Admin and Site Enhancements (ASE) to version 7.5.2 or newer.
- Official ID
- CVE-2024-10790
- Report title
- Admin and Site Enhancements (ASE) <= 7.5.1 - Authenticated Stored Cross-Site Scripting via SVG
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site (up to and including 5.7.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.7.1
- Fixed in
- 5.8.0
- What to do
- If your site has an affected version, update Admin and Site Enhancements (ASE) to version 5.8.0 or newer.
- Official ID
- CVE-2023-46630
- Report title
- Admin and Site Enhancements (ASE) <= 5.7.1 - Password Protection Mode Security Feature Bypass
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)