Advanced Ads – Ad Manager & AdSense: known security problems
11 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 11 known security problems on this page. Each one has a fixed version. Updating to version 2.0.27 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Anyone with an account on your site, even a basic one could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.26
- Fixed in
- 2.0.27
- What to do
- If your site has an affected version, update Advanced Ads – Ad Manager & AdSense to version 2.0.27 or newer.
- Official ID
- CVE-2026-94180
- Report title
- Advanced Ads – Ad Manager & AdSense <= 2.0.26 - Authenticated (Subscriber+) Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.0.22)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.22
- Fixed in
- 2.0.23
- What to do
- If your site has an affected version, update Advanced Ads – Ad Manager & AdSense to version 2.0.23 or newer.
- Official ID
- CVE-2026-10082
- Report title
- Advanced Ads – Ad Manager & AdSense <= 2.0.22 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could run their own code on your site and take it over
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.21
- Fixed in
- 2.0.22
- What to do
- If your site has an affected version, update Advanced Ads – Ad Manager & AdSense to version 2.0.22 or newer.
- Official ID
- CVE-2026-54816
- Report title
- Advanced Ads – Ad Manager & AdSense <= 2.0.21 - Authenticated (Contributor+) Remote Code Execution
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.14
- Fixed in
- 2.0.15
- What to do
- If your site has an affected version, update Advanced Ads – Ad Manager & AdSense to version 2.0.15 or newer.
- Official ID
- CVE-2025-12884
- Report title
- Advanced Ads – Ad Manager & AdSense <= 2.0.14 - Missing Authorization to Authenticated (Subscriber+) Ad Placements Update
- First reported
- Sources
- Wordfence, seen
Someone could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.15
- Fixed in
- 2.0.16
- What to do
- If your site has an affected version, update Advanced Ads – Ad Manager & AdSense to version 2.0.16 or newer.
- Official ID
- CVE-2025-12984
- Report title
- Advanced Ads – Ad Manager & AdSense <= 2.0.15 - Authenticated (Admin+) SQL Injection
- First reported
- Sources
- Wordfence, seen
Someone with an editor account on your site could run their own code on your site and take it over
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.14
- Fixed in
- 2.0.15
- What to do
- If your site has an affected version, update Advanced Ads – Ad Manager & AdSense to version 2.0.15 or newer.
- Official ID
- CVE-2025-13592
- Report title
- Advanced Ads <= 2.0.14 - Authenticated (Editor+) Remote Code Execution via Shortcode
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.12
- Fixed in
- 2.0.13
- What to do
- If your site has an affected version, update Advanced Ads – Ad Manager & AdSense to version 2.0.13 or newer.
- Official ID
- CVE-2025-10487
- Report title
- Advanced Ads <= 2.0.12 - Unauthenticated Limited Code Execution
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.52.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.52.1
- Fixed in
- 1.52.2
- What to do
- If your site has an affected version, update Advanced Ads – Ad Manager & AdSense to version 1.52.2 or newer.
- Official ID
- CVE-2024-3952
- Report title
- Advanced Ads – Ad Manager & AdSense <= 1.52.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Ad Widget
- First reported
- Sources
- Wordfence, seen
Someone could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.52.1
- Fixed in
- 1.52.2
- What to do
- If your site has an affected version, update Advanced Ads – Ad Manager & AdSense to version 1.52.2 or newer.
- Official ID
- CVE-2024-2290
- Report title
- Advanced Ads – Ad Manager & AdSense <= 1.52.1 - Authenticated (Admin+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.31.1
- Fixed in
- 1.32.0
- What to do
- If your site has an affected version, update Advanced Ads – Ad Manager & AdSense to version 1.32.0 or newer.
- Official ID
- CVE-2022-32776
- Report title
- Advanced Ads – Ad Manager & AdSense <= 1.31.1 - Authenticated (Administrator+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 1.17.4
- Fixed in
- 1.17.4
- What to do
- If your site has an affected version, update Advanced Ads – Ad Manager & AdSense to version 1.17.4 or newer.
- Report title
- Advanced Ads <= 1.17.3 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)