EN ES
Start free

Advanced Woo Labels: known security problems

7 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 7 known security problems on this page. Each one has a fixed version. Updating to version 2.52 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Anyone with an account on your site, even a basic one could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.51
Fixed in
2.52
What to do
If your site has an affected version, update Advanced Woo Labels to version 2.52 or newer.
Official ID
CVE-2026-12241
Report title
Advanced Woo Labels – Product Labels & Badges for WooCommerce <= 2.51 - Improper Authorization to Authenticated (Subscriber+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.48)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.48
Fixed in
2.49
What to do
If your site has an affected version, update Advanced Woo Labels to version 2.49 or newer.
Official ID
CVE-2026-15662
Report title
Advanced Woo Labels <= 2.48 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'bg_color' Parameter
First reported
Sources
This week

Someone could run their own code on your site and take it over

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.36
Fixed in
2.37
What to do
If your site has an affected version, update Advanced Woo Labels to version 2.37 or newer.
Official ID
CVE-2026-32414
Report title
Advanced Woo Labels <= 2.36 - Authenticated (Admin+) Remote Code Execution
First reported
Sources
This week

Someone with a contributor account on your site could run their own code on your site and take it over

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.36
Fixed in
2.37
What to do
If your site has an affected version, update Advanced Woo Labels to version 2.37 or newer.
Official ID
CVE-2026-1929
Report title
Advanced Woo Labels <= 2.37 - Authenticated (Contributor+) Remote Code Execution via 'callback' Parameter
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.15)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.15
Fixed in
2.16
What to do
If your site has an affected version, update Advanced Woo Labels to version 2.16 or newer.
Official ID
CVE-2025-32188
Report title
Advanced Woo Labels <= 2.15 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.01)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.01
Fixed in
2.02
What to do
If your site has an affected version, update Advanced Woo Labels to version 2.02 or newer.
Official ID
CVE-2024-47622
Report title
Advanced Woo Labels <= 2.01 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.93)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.93
Fixed in
1.94
What to do
If your site has an affected version, update Advanced Woo Labels to version 1.94 or newer.
Official ID
CVE-2024-35675
Report title
Advanced Woo Labels – Product Labels for WooCommerce <= 1.93 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)