Agile Store Locator: known security problems
11 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 11 known security problems on this page. Each one has a fixed version. Updating to version 1.6.9 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone who already has an admin account could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 1.6.6
- Fixed in
- 1.6.6
- What to do
- If your site has an affected version, update Agile Store Locator to version 1.6.6 or newer.
- Official ID
- CVE-2026-9060
- Report title
- Store Locator WordPress < 1.6.6 - Authenticated (Administrator+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.8
- Fixed in
- 1.6.9
- What to do
- If your site has an affected version, update Agile Store Locator to version 1.6.9 or newer.
- Official ID
- CVE-2026-9062
- Report title
- Agile Store Locator <= 1.6.8 - Authenticated (Admin+) Arbitrary File Read
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.6.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.8
- Fixed in
- 1.6.9
- What to do
- If your site has an affected version, update Agile Store Locator to version 1.6.9 or newer.
- Official ID
- CVE-2026-9061
- Report title
- Agile Store Locator <= 1.6.8 - Authenticated (Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.2
- Fixed in
- 1.6.3
- What to do
- If your site has an affected version, update Agile Store Locator to version 1.6.3 or newer.
- Official ID
- CVE-2025-67516
- Report title
- Store Locator WordPress <= 1.6.2 - Authenticated (Contributor+) SQL Injection
- First reported
- Sources
- Wordfence, seen
Someone could run their own code on your site and take it over
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.2
- Fixed in
- 1.5.3
- What to do
- If your site has an affected version, update Agile Store Locator to version 1.5.3 or newer.
- Official ID
- CVE-2025-49329
- Report title
- Store Locator WordPress <= 1.5.2 - Authenticated (Admin+) Arbitrary File Upload
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.1
- Fixed in
- 1.5.2
- What to do
- If your site has an affected version, update Agile Store Locator to version 1.5.2 or newer.
- Official ID
- CVE-2025-49328
- Report title
- Store Locator WordPress <= 1.5.1 - Authenticated (Administrator+) SQL Injection
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.4.14
- Fixed in
- 1.4.15
- What to do
- If your site has an affected version, update Agile Store Locator to version 1.4.15 or newer.
- Official ID
- CVE-2023-50885
- Report title
- Store Locator WordPress <= 1.4.14 - Authenticated(Administrator+) Directory Traversal to Arbitrary File Deletion
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.4.12)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.4.12
- Fixed in
- 1.4.13
- What to do
- If your site has an affected version, update Agile Store Locator to version 1.4.13 or newer.
- Official ID
- CVE-2023-4151
- Report title
- Store Locator WordPress <= 1.4.12 - Reflected Cross-Site Scripting via 'asl-nounce'
- First reported
- Sources
- Wordfence, seen
Someone with an editor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.4.9
- Fixed in
- 1.4.10
- What to do
- If your site has an affected version, update Agile Store Locator to version 1.4.10 or newer.
- Official ID
- CVE-2023-27618
- Report title
- Store Locator WordPress <= 1.4.9 - Authenticated (Editor+) Stored Cross-Site Scripting via 'category_name', 'description', 'description_2' parameters
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.4.8
- Fixed in
- 1.4.9
- What to do
- If your site has an affected version, update Agile Store Locator to version 1.4.9 or newer.
- Official ID
- CVE-2022-4832
- Report title
- Store Locator WordPress <= 1.4.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.4.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.4.5
- Fixed in
- 1.4.6
- What to do
- If your site has an affected version, update Agile Store Locator to version 1.4.6 or newer.
- Official ID
- CVE-2022-41615
- Report title
- Store Locator WordPress <= 1.4.5 - Cross-Site Request Forgery to Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)