bbPress: known security problems
9 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 9 known security problems on this page. 8 of them have a fixed version. Updating to version 2.6.15 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could use it to harm your site (before 2.6.19)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.6.19
- Fixed in
- No fixed version yet
- What to do
- There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
- Official ID
- CVE-2026-110762
- Report title
- bbPress < 2.6.19 - Unauthenticated Information Exposure
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site (up to and including 2.6.14)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.14
- Fixed in
- 2.6.15
- What to do
- If your site has an affected version, update bbPress to version 2.6.15 or newer.
- Official ID
- CVE-2026-62137
- Report title
- bbPress <= 2.6.14 - Unauthenticated Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.14
- Fixed in
- 2.6.15
- What to do
- If your site has an affected version, update bbPress to version 2.6.15 or newer.
- Official ID
- CVE-2026-74010
- Report title
- bbPress <= 2.6.14 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could take over your site as an admin
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.11
- Fixed in
- 2.6.12
- What to do
- If your site has an affected version, update bbPress to version 2.6.12 or newer.
- Official ID
- CVE-2025-1435
- Report title
- bbPress <= 2.6.11 - Cross-Site Request Forgery to Limited Privilege Escalation
- First reported
- Sources
- Wordfence, seen
A stranger could take over your site as an admin
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.4
- Fixed in
- 2.6.5
- What to do
- If your site has an affected version, update bbPress to version 2.6.5 or newer.
- Official ID
- CVE-2020-13693
- Report title
- bbPress <= 2.6.4 - Unauthenticated Privilege Escalation
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.6.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.4
- Fixed in
- 2.6.5
- What to do
- If your site has an affected version, update bbPress to version 2.6.5 or newer.
- Official ID
- CVE-2020-13487
- Report title
- bbPress <= 2.6.4 - Authenticated (Admin+) Stored Cross-Site Scripting via the forums list table
- First reported
- Sources
- Wordfence, seen
A stranger could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.5.13
- Fixed in
- 2.5.13
- What to do
- If your site has an affected version, update bbPress to version 2.5.13 or newer.
- Report title
- bbPress < 2.5.13 - Unauthenticated Blind SQL Injection
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.5.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.5.9
- Fixed in
- 2.5.10
- What to do
- If your site has an affected version, update bbPress to version 2.5.10 or newer.
- Report title
- bbPress <= 2.5.9 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 2.5.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.5.9
- Fixed in
- 2.5.9
- What to do
- If your site has an affected version, update bbPress to version 2.5.9 or newer.
- Report title
- bbPress < 2.5.9 - Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)