EN ES
Start free

BlockSpare – Gutenberg Blocks, AI Content Generator & Site Builder for news, magazine, blog and business sites: known security problems

10 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 10 known security problems on this page. Each one has a fixed version. Updating to version 5.0.0 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Anyone with an account on your site, even a basic one could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.2.6
Fixed in
5.0.0
What to do
If your site has an affected version, update BlockSpare – Gutenberg Blocks, AI Content Generator & Site Builder for news, magazine, blog and business sites to version 5.0.0 or newer.
Official ID
CVE-2026-1242
Report title
BlockSpare - Gutenberg Site Builder Blocks & Starter Sites <= 4.2.6 - Incorrect Authorization to Authenticated (Subscriber+) Arbitrary Post Creation
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 3.2.6)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.2.6
Fixed in
3.2.8
What to do
If your site has an affected version, update BlockSpare – Gutenberg Blocks, AI Content Generator & Site Builder for news, magazine, blog and business sites to version 3.2.8 or newer.
Official ID
CVE-2024-13362
Report title
Freemius <= 2.10.1 - Reflected DOM-Based Cross-Site Scripting via url Parameter
First reported
Sources
This week

Someone with a contributor account on your site could see private information they should not see

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.2.13.2
Fixed in
3.2.14
What to do
If your site has an affected version, update BlockSpare – Gutenberg Blocks, AI Content Generator & Site Builder for news, magazine, blog and business sites to version 3.2.14 or newer.
Official ID
CVE-2025-62026
Report title
Blockspare <= 3.2.13.2 - Authenticated (Contributor+) Sensitive Information Exposure
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.2.13.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.2.13.1
Fixed in
3.2.13.2
What to do
If your site has an affected version, update BlockSpare – Gutenberg Blocks, AI Content Generator & Site Builder for news, magazine, blog and business sites to version 3.2.13.2 or newer.
Official ID
CVE-2025-4684
Report title
BlockSpare: Gutenberg Blocks & Patterns for Blogs, Magazines, Business Sites <= 3.2.13.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Image Carousel and Image Slider Widgets
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.2.9)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.2.9
Fixed in
3.2.10
What to do
If your site has an affected version, update BlockSpare – Gutenberg Blocks, AI Content Generator & Site Builder for news, magazine, blog and business sites to version 3.2.10 or newer.
Official ID
CVE-2025-47495
Report title
Blockspare <= 3.2.9 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.2.4)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.2.4
Fixed in
3.2.5
What to do
If your site has an affected version, update BlockSpare – Gutenberg Blocks, AI Content Generator & Site Builder for news, magazine, blog and business sites to version 3.2.5 or newer.
Official ID
CVE-2024-47363
Report title
Blockspare <= 3.2.4 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.2.4) (2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.2.4
Fixed in
3.2.5
What to do
If your site has an affected version, update BlockSpare – Gutenberg Blocks, AI Content Generator & Site Builder for news, magazine, blog and business sites to version 3.2.5 or newer.
Official ID
CVE-2024-8325
Report title
Gutenberg Page Builder Blocks & Ready-Made Patterns Library <= 3.2.4 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.2.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.2.0
Fixed in
3.2.1
What to do
If your site has an affected version, update BlockSpare – Gutenberg Blocks, AI Content Generator & Site Builder for news, magazine, blog and business sites to version 3.2.1 or newer.
Official ID
CVE-2024-43164
Report title
Blockspare <= 3.2.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 2.6.4)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.6.4
Fixed in
2.6.5
What to do
If your site has an affected version, update BlockSpare – Gutenberg Blocks, AI Content Generator & Site Builder for news, magazine, blog and business sites to version 2.6.5 or newer.
Official ID
CVE-2023-33999
Report title
Freemius SDK <= 2.5.9 - Reflected Cross-Site Scripting via fs_request_get
First reported
Sources
This week

Someone could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 2.0.1
Fixed in
2.0.1
What to do
If your site has an affected version, update BlockSpare – Gutenberg Blocks, AI Content Generator & Site Builder for news, magazine, blog and business sites to version 2.0.1 or newer.
Official ID
CVE-2022-4974
Report title
Freemius SDK <= 2.4.2 - Missing Authorization Checks
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)