BulletProof Security: known security problems
12 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 12 known security problems on this page. Each one has a fixed version. Updating to version 7.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could see private information they should not see
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 6.9
- Fixed in
- 7.0
- What to do
- If your site has an affected version, update BulletProof Security to version 7.0 or newer.
- Official ID
- CVE-2025-67931
- Report title
- BulletProof Security <= 6.9 - Unauthenticated Sensitive Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 6.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 6.1
- Fixed in
- 6.1
- What to do
- If your site has an affected version, update BulletProof Security to version 6.1 or newer.
- Official ID
- CVE-2022-1265
- Report title
- BulletProof Security <= 6.0 - Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 5.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 5.8
- Fixed in
- 5.8
- What to do
- If your site has an affected version, update BulletProof Security to version 5.8 or newer.
- Official ID
- CVE-2022-0590
- Report title
- BulletProof Security <= 5.7 - Admin+ Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.1
- Fixed in
- 5.2
- What to do
- If your site has an affected version, update BulletProof Security to version 5.2 or newer.
- Official ID
- CVE-2021-39327
- Report title
- BulletProof Security <= 5.1 - Sensitive Information Disclosure
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before .53.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before .53.4
- Fixed in
- .53.4
- What to do
- If your site has an affected version, update BulletProof Security to version .53.4 or newer.
- Report title
- BulletProof Security <= .53.3 - Authenticated Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including .53.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including .53.2
- Fixed in
- .53.3
- What to do
- If your site has an affected version, update BulletProof Security to version .53.3 or newer.
- Report title
- BulletProof Security <= .53.2 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before .51.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before .51.1
- Fixed in
- .51.1
- What to do
- If your site has an affected version, update BulletProof Security to version .51.1 or newer.
- Official ID
- CVE-2014-7958
- Report title
- BulletProof Security < .51.1 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could make your server visit other addresses on their behalf
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including .51
- Fixed in
- .51.1
- What to do
- If your site has an affected version, update BulletProof Security to version .51.1 or newer.
- Official ID
- CVE-2014-8749
- Report title
- BulletProof Security < .51.1 - Server-Side Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before .51.1
- Fixed in
- .51.1
- What to do
- If your site has an affected version, update BulletProof Security to version .51.1 or newer.
- Official ID
- CVE-2014-7959
- Report title
- BulletProof Security < .51.1 - SQL Injection
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before .52.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before .52.5
- Fixed in
- .52.5
- What to do
- If your site has an affected version, update BulletProof Security to version .52.5 or newer.
- Official ID
- CVE-2015-9230
- Report title
- BulletProof Security < .52.5 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including .48.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including .48.9
- Fixed in
- .49
- What to do
- If your site has an affected version, update BulletProof Security to version .49 or newer.
- Official ID
- CVE-2013-3487
- Report title
- BulletProof Security <= .48.9 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before .47.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before .47.1
- Fixed in
- .47.1
- What to do
- If your site has an affected version, update BulletProof Security to version .47.1 or newer.
- Official ID
- CVE-2012-4268
- Report title
- BulletProof Security < .47.1 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)