EN ES
Start free

PublishPress Capabilities: known security problems

9 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 9 known security problems on this page. Each one has a fixed version. Updating to version 2.51.0 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone could trick a logged-in admin into changing settings without knowing

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.50.1
Fixed in
2.51.0
What to do
If your site has an affected version, update PublishPress Capabilities to version 2.51.0 or newer.
Official ID
CVE-2026-94487
Report title
PublishPress Capabilities: User Role Access Control, Admin Area Permissions <= 2.50.1 - Cross-Site Request Forgery
First reported
Sources
This week

Someone with an editor account on your site could take over your site as an admin (up to and including 2.50.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.50.0
Fixed in
2.50.1
What to do
If your site has an affected version, update PublishPress Capabilities to version 2.50.1 or newer.
Official ID
CVE-2026-75927
Report title
PublishPress Capabilities <= 2.50.0 - Authenticated (Editor+) Privilege Escalation to Fresh-Install Default Capability Grant
First reported
Sources
This week

Someone with an editor account on your site could take over your site as an admin (up to and including 2.45.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.45.0
Fixed in
2.50.0
What to do
If your site has an affected version, update PublishPress Capabilities to version 2.50.0 or newer.
Official ID
CVE-2026-28183
Report title
PublishPress Capabilities: User Role Access Control, Admin Area Permissions <= 2.45.0 - Authenticated (Editor+) Privilege Escalation
First reported
Sources
This week

Someone with an editor account on your site could take over your site as an admin (up to and including 2.45.0) (2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.45.0
Fixed in
2.50.0
What to do
If your site has an affected version, update PublishPress Capabilities to version 2.50.0 or newer.
Official ID
CVE-2026-48197
Report title
PublishPress Capabilities: User Role Access Control, Admin Area Permissions <= 2.45.0 - Authenticated (Editor+) Privilege Escalation
First reported
Sources
This week

Someone could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.31.0
Fixed in
2.32.0
What to do
If your site has an affected version, update PublishPress Capabilities to version 2.32.0 or newer.
Official ID
CVE-2026-32394
Report title
PublishPress Capabilities <= 2.31.0 - Missing Authorization
First reported
Sources
This week

Someone who already has an admin account could in some setups, take over your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.5.1
Fixed in
2.5.2
What to do
If your site has an affected version, update PublishPress Capabilities to version 2.5.2 or newer.
Official ID
CVE-2022-3366
Report title
PublishPress Capabilities <= 2.5.1 - Authenticated (Administrator+) PHP Object Injection
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.3.2
Fixed in
2.3.3
What to do
If your site has an affected version, update PublishPress Capabilities to version 2.3.3 or newer.
Report title
PublishPress Capabilities <= 2.3.2 - Reflected Cross-Site Scripting
First reported
Sources
This week

A stranger could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 2.3.1
Fixed in
2.3.1
What to do
If your site has an affected version, update PublishPress Capabilities to version 2.3.1 or newer.
Official ID
CVE-2021-25032
Report title
PublishPress Capabilities <= 2.3 - Unauthenticated Arbitrary Options Update
First reported
Sources
This week

Someone could read or change the data in your site’s database

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 1.5.9
Fixed in
1.5.9
What to do
If your site has an affected version, update PublishPress Capabilities to version 1.5.9 or newer.
Report title
PublishPress Capabilities <= 1.5.8 - Authenticated SQL Injection
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)