EN ES
Start free

CartFlows – Funnel Builder & Checkout Plugin for WooCommerce: known security problems

9 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 9 known security problems on this page. Each one has a fixed version. Updating to version 3.2.1 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone with a contributor account on your site could run their own code on your site and take it over

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.2.0
Fixed in
3.2.1
What to do
If your site has an affected version, update CartFlows – Funnel Builder & Checkout Plugin for WooCommerce to version 3.2.1 or newer.
Official ID
CVE-2026-96837
Report title
CartFlows – Funnel Builder & Checkout Plugin for WooCommerce <= 3.2.0 - Authenticated (Contributor+) Remote Code Execution
First reported
Sources
This week

Someone could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.3
Fixed in
2.2.4
What to do
If your site has an affected version, update CartFlows – Funnel Builder & Checkout Plugin for WooCommerce to version 2.2.4 or newer.
Official ID
CVE-2026-39477
Report title
CartFlows <= 2.2.3 - Missing Authorization
First reported
Sources
This week

Someone who already has an admin account could in some setups, take over your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.1.19
Fixed in
2.2.0
What to do
If your site has an affected version, update CartFlows – Funnel Builder & Checkout Plugin for WooCommerce to version 2.2.0 or newer.
Official ID
CVE-2026-25316
Report title
CartFlows – Checkout & Funnel Builder for WooCommerce <= 2.1.19 - Authenticated (Administrator+) PHP Object Injection
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.0.7
Fixed in
2.0.8
What to do
If your site has an affected version, update CartFlows – Funnel Builder & Checkout Plugin for WooCommerce to version 2.0.8 or newer.
Official ID
CVE-2024-4632
Report title
WooCommerce Checkout & Funnel Builder by CartFlows – Create High Converting Stores For WooCommerce <= 2.0.7 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with an editor account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.0.1
Fixed in
2.0.2
What to do
If your site has an affected version, update CartFlows – Funnel Builder & Checkout Plugin for WooCommerce to version 2.0.2 or newer.
Official ID
CVE-2024-29813
Report title
Funnel Builder by CartFlows <= 2.0.1 - Authenticated (Editor+) Stored Cross-Site Scripting via settings
First reported
Sources
This week

Someone could use it to harm your site (before 1.11.12)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 1.11.12
Fixed in
1.11.12
What to do
If your site has an affected version, update CartFlows – Funnel Builder & Checkout Plugin for WooCommerce to version 1.11.12 or newer.
Report title
CartFlows <= 1.11.11 - Insecure Direct Object Reference to Arbitrary Post Deletion
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 1.6.13
Fixed in
1.6.13
What to do
If your site has an affected version, update CartFlows – Funnel Builder & Checkout Plugin for WooCommerce to version 1.6.13 or newer.
Official ID
CVE-2021-24330
Report title
Funnel Builder by CartFlows <= 1.6.12 - Authenticated Stored Cross-Site scripting via FB Pixel ID and Google Analytics ID
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 1.5.16
Fixed in
1.5.16
What to do
If your site has an affected version, update CartFlows – Funnel Builder & Checkout Plugin for WooCommerce to version 1.5.16 or newer.
Official ID
CVE-2020-36736
Report title
WooCommerce Checkout & Funnel Builder by CartFlows – Create High Converting Stores For WooCommerce <= 1.5.15 - Cross-Site Request Forgery Bypass
First reported
Sources
This week

Someone could use it to harm your site (up to and including 1.3.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.3.0
Fixed in
1.3.1
What to do
If your site has an affected version, update CartFlows – Funnel Builder & Checkout Plugin for WooCommerce to version 1.3.1 or newer.
Official ID
CVE-2019-25151
Report title
Funnel Builder <= 1.3.0 - Arbitrary Plugin Activation
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)