EN ES
Start free

Floating Chat Widget: known security problems

12 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 12 known security problems on this page. Each one has a fixed version. Updating to version 3.6.0 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 3.5.9)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.5.9
Fixed in
3.6.0
What to do
If your site has an affected version, update Floating Chat Widget to version 3.6.0 or newer.
Official ID
CVE-2026-18964
Report title
Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button <= 3.5.9 - Reflected Cross-Site Scripting
First reported
Sources
This week

A stranger could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.5.1
Fixed in
3.5.2
What to do
If your site has an affected version, update Floating Chat Widget to version 3.5.2 or newer.
Official ID
CVE-2026-27370
Report title
Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button – Chaty <= 3.5.1 - Unauthenticated Information Exposure
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.3.5
Fixed in
3.3.6
What to do
If your site has an affected version, update Floating Chat Widget to version 3.3.6 or newer.
Official ID
CVE-2025-1450
Report title
Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button, WhatsApp – Chaty <= 3.3.5 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 3.2.2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.2.2
Fixed in
3.2.3
What to do
If your site has an affected version, update Floating Chat Widget to version 3.2.3 or newer.
Official ID
CVE-2024-4149
Report title
Floating Chat Widget: Contact Chat Icons, WhatsApp, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button – Chaty <= 3.2.2 - Authenticated (Admin+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with an editor account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.1.8
Fixed in
3.1.9
What to do
If your site has an affected version, update Floating Chat Widget to version 3.1.9 or newer.
Official ID
CVE-2024-2972
Report title
Floating Chat Widget <= 3.1.8 - Authenticated (Editor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone who already has an admin account could plant harmful code that runs for your visitors or admins (up to and including 3.1.2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.1.2
Fixed in
3.1.3
What to do
If your site has an affected version, update Floating Chat Widget to version 3.1.3 or newer.
Official ID
CVE-2023-47759
Report title
Chaty <= 3.1.2 - Authenticated (Administrator+) Stored Cross-Site Scripting via settings
First reported
Sources
This week

Someone who already has an admin account could plant harmful code that runs for your visitors or admins (up to and including 3.1.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.1.1
Fixed in
3.1.2
What to do
If your site has an affected version, update Floating Chat Widget to version 3.1.2 or newer.
Official ID
CVE-2023-3245
Report title
Floating Chat Widget - Chaty <= 3.1.1 - Authenticated (Administrator+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 3.0.9)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.0.9
Fixed in
3.1
What to do
If your site has an affected version, update Floating Chat Widget to version 3.1 or newer.
Official ID
CVE-2023-25019
Report title
Chaty <= 3.0.9 - Reflected Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 3.0.9) (2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.0.9
Fixed in
3.1
What to do
If your site has an affected version, update Floating Chat Widget to version 3.1 or newer.
Report title
Chaty <= 3.0.9 - Authenticated (Admin+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone who already has an admin account could read or change the data in your site’s database

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.0.2
Fixed in
3.0.3
What to do
If your site has an affected version, update Floating Chat Widget to version 3.0.3 or newer.
Official ID
CVE-2022-3858
Report title
Floating Chat Widget - Chaty <= 3.0.2 - Authenticated (Administrator+) SQL Injection
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 2.8.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.8.3
Fixed in
2.8.5
What to do
If your site has an affected version, update Floating Chat Widget to version 2.8.5 or newer.
Official ID
CVE-2021-36846
Report title
Floating Chat Widget: Contact Icons, Messages, Telegram, Email, SMS, Call Button – Chaty <= 2.8.3 - Admin+ Stored Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (before 2.8.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 2.8.3
Fixed in
2.8.3
What to do
If your site has an affected version, update Floating Chat Widget to version 2.8.3 or newer.
Official ID
CVE-2021-25016
Report title
Floating Chat Widget: Contact Icons, Messages, Telegram, Email, SMS, Call Button - Chaty <= 2.8.2 Reflected Cross-Site Scripting
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)