EN ES
Start free

Page Builder Gutenberg Blocks – CoBlocks: known security problems

8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 8 known security problems on this page. Each one has a fixed version. Updating to version 3.1.17 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.1.16)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.1.16
Fixed in
3.1.17
What to do
If your site has an affected version, update Page Builder Gutenberg Blocks – CoBlocks to version 3.1.17 or newer.
Official ID
CVE-2026-4801
Report title
Page Builder Gutenberg Blocks <= 3.1.16 - Authenticated (Contributor+) Stored Cross-Site Scripting via External iCal Feed Data
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.1.16) (2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.1.16
Fixed in
3.1.17
What to do
If your site has an affected version, update Page Builder Gutenberg Blocks – CoBlocks to version 3.1.17 or newer.
Official ID
CVE-2026-27094
Report title
Page Builder Gutenberg Blocks – CoBlocks <= 3.1.16 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.1.13
Fixed in
3.1.14
What to do
If your site has an affected version, update Page Builder Gutenberg Blocks – CoBlocks to version 3.1.14 or newer.
Official ID
CVE-2025-24751
Report title
CoBlocks <= 3.1.13 - Missing Authorization
First reported
Sources
This week

Someone with an editor account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.1.12
Fixed in
3.1.13
What to do
If your site has an affected version, update Page Builder Gutenberg Blocks – CoBlocks to version 3.1.13 or newer.
Official ID
CVE-2024-7132
Report title
Page Builder Gutenberg Blocks – CoBlocks <= 3.1.12 - Authenticated (Editor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could make your server visit other addresses on their behalf

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.1.11
Fixed in
3.1.12
What to do
If your site has an affected version, update Page Builder Gutenberg Blocks – CoBlocks to version 3.1.12 or newer.
Official ID
CVE-2024-4260
Report title
Page Builder Gutenberg Blocks – CoBlocks <= 3.1.11 - Authenticated (Contributor+) Server-Side Request Forgery
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.1.9)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.1.9
Fixed in
3.1.10
What to do
If your site has an affected version, update Page Builder Gutenberg Blocks – CoBlocks to version 3.1.10 or newer.
Official ID
CVE-2024-2933
Report title
Page Builder Gutenberg Blocks – CoBlocks <= 3.1.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Social Profiles
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.1.6)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.1.6
Fixed in
3.1.7
What to do
If your site has an affected version, update Page Builder Gutenberg Blocks – CoBlocks to version 3.1.7 or newer.
Official ID
CVE-2024-1049
Report title
Page Builder Gutenberg Blocks – CoBlocks <= 3.1.6 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.1.6) (2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.1.6
Fixed in
3.1.7
What to do
If your site has an affected version, update Page Builder Gutenberg Blocks – CoBlocks to version 3.1.7 or newer.
Official ID
CVE-2024-2369
Report title
Page Builder Gutenberg Blocks – CoBlocks <= 3.1.6 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)