Content Control: known security problems
5 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 5 known security problems on this page. 4 of them have a fixed version. Updating to version 2.6.2 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.5
- Fixed in
- No fixed version yet
- What to do
- There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
- Official ID
- CVE-2026-65485
- Report title
- Content Control – The Ultimate Content Restriction Plugin! Restrict Content, Create Conditional Blocks & More <= 2.6.5 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.6.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.1
- Fixed in
- 2.6.2
- What to do
- If your site has an affected version, update Content Control to version 2.6.2 or newer.
- Official ID
- CVE-2025-47501
- Report title
- Content Control <= 2.6.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
A stranger could see private information they should not see
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.5.0
- Fixed in
- 2.6.0
- What to do
- If your site has an affected version, update Content Control to version 2.6.0 or newer.
- Official ID
- CVE-2024-11153
- Report title
- Content Control – The Ultimate Content Restriction Plugin! Restrict Content, Create Conditional Blocks & More <= 2.5.0 - Unauthenticated Content Restriction Bypass to Sensitive Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone could see private information they should not see
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.0
- Fixed in
- 2.2.0
- What to do
- If your site has an affected version, update Content Control to version 2.2.0 or newer.
- Official ID
- CVE-2024-0615
- Report title
- Content Control <= 2.1.0 - Missing Authorization to Sensitive Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.1.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.1.9
- Fixed in
- 1.1.10
- What to do
- If your site has an affected version, update Content Control to version 1.1.10 or newer.
- Official ID
- CVE-2022-4509
- Report title
- Content Control <= 1.1.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)