Kit (formerly ConvertKit) – Email Newsletter, Email Marketing, Membership, Subscribers and Landing Pages: known security problems
6 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 6 known security problems on this page. Each one has a fixed version. Updating to version 3.4.7 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could do things on your site they should not be allowed to (up to and including 3.4.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.4.6
- Fixed in
- 3.4.7
- What to do
- If your site has an affected version, update Kit (formerly ConvertKit) – Email Newsletter, Email Marketing, Membership, Subscribers and Landing Pages to version 3.4.7 or newer.
- Official ID
- CVE-2026-110880
- Report title
- Kit (formerly ConvertKit) – Email Newsletter, Email Marketing, Membership, Subscribers and Landing Pages <= 3.4.6 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.3.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.5
- Fixed in
- 3.3.6
- What to do
- If your site has an affected version, update Kit (formerly ConvertKit) – Email Newsletter, Email Marketing, Membership, Subscribers and Landing Pages to version 3.3.6 or newer.
- Official ID
- CVE-2026-65472
- Report title
- Kit (formerly ConvertKit) – Email Newsletter, Email Marketing, Membership, Subscribers and Landing Pages <= 3.3.5 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 2.4.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.9
- Fixed in
- 2.4.9.1
- What to do
- If your site has an affected version, update Kit (formerly ConvertKit) – Email Newsletter, Email Marketing, Membership, Subscribers and Landing Pages to version 2.4.9.1 or newer.
- Official ID
- CVE-2024-3961
- Report title
- ConvertKit <= 2.4.9 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
A stranger could see private information they should not see
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.5
- Fixed in
- 2.4.6
- What to do
- If your site has an affected version, update Kit (formerly ConvertKit) – Email Newsletter, Email Marketing, Membership, Subscribers and Landing Pages to version 2.4.6 or newer.
- Official ID
- CVE-2024-31245
- Report title
- ConvertKit <= 2.4.5 - Unauthenticated Sensitive Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.0
- Fixed in
- 2.2.1
- What to do
- If your site has an affected version, update Kit (formerly ConvertKit) – Email Newsletter, Email Marketing, Membership, Subscribers and Landing Pages to version 2.2.1 or newer.
- Official ID
- CVE-2023-2337
- Report title
- ConvertKit <= 2.2.0 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.4
- Fixed in
- 2.0.5
- What to do
- If your site has an affected version, update Kit (formerly ConvertKit) – Email Newsletter, Email Marketing, Membership, Subscribers and Landing Pages to version 2.0.5 or newer.
- Official ID
- CVE-2022-4508
- Report title
- ConvertKit <= 2.0.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)