EN ES
Start free

Custom Post Type UI: known security problems

4 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 4 known security problems on this page. Each one has a fixed version. Updating to version 1.18.2 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone who already has an admin account could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.18.1
Fixed in
1.18.2
What to do
If your site has an affected version, update Custom Post Type UI to version 1.18.2 or newer.
Official ID
CVE-2025-14056
Report title
Custom Post Type UI <= 1.18.1 - Authenticated (Administrator+) Stored Cross-Site Scripting via 'label' Import Parameter
First reported
Sources
This week

A stranger could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.18.0
Fixed in
1.18.1
What to do
If your site has an affected version, update Custom Post Type UI to version 1.18.1 or newer.
Official ID
CVE-2025-12826
Report title
Custom Post Type UI <= 1.18.0 - Missing Authorization to Unauthenticated (Previously Administrator+) Custom Post Type Modification
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.13.4
Fixed in
1.13.5
What to do
If your site has an affected version, update Custom Post Type UI to version 1.13.5 or newer.
Official ID
CVE-2023-1623
Report title
Custom Post Type UI <= 1.13.4 - Cross-Site Request Forgery to Sensitive Information Exposure
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 1.7.4
Fixed in
1.7.4
What to do
If your site has an affected version, update Custom Post Type UI to version 1.7.4 or newer.
Report title
Custom Post Type UI <= 1.7.3 - Cross-Site Request Forgery to Stored Cross-Site Scripting
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)