Content Blocks (Custom Post Widget): known security problems
6 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 6 known security problems on this page. Each one has a fixed version. Updating to version 3.4.1 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with an author account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.9
- Fixed in
- 3.4.1
- What to do
- If your site has an affected version, update Content Blocks (Custom Post Widget) to version 3.4.1 or newer.
- Official ID
- CVE-2026-0894
- Report title
- Content Blocks (Custom Post Widget) <= 3.3.9 - Authenticated (Author+) Stored Cross-Site Scripting via content_block Shortcode
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.3.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.5
- Fixed in
- 3.3.6
- What to do
- If your site has an affected version, update Content Blocks (Custom Post Widget) to version 3.3.6 or newer.
- Official ID
- CVE-2024-6432
- Report title
- Content Blocks (Custom Post Widget) <= 3.3.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via content Parameter
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.3.5) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.5
- Fixed in
- 3.3.6
- What to do
- If your site has an affected version, update Content Blocks (Custom Post Widget) to version 3.3.6 or newer.
- Official ID
- CVE-2024-44051
- Report title
- Content Blocks (Custom Post Widget) <= 3.3.5 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.3.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.0
- Fixed in
- 3.3.1
- What to do
- If your site has an affected version, update Content Blocks (Custom Post Widget) to version 3.3.1 or newer.
- Official ID
- CVE-2024-3565
- Report title
- Content Blocks (Custom Post Widget) <= 3.3.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via content_block Shortcode
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.0
- Fixed in
- 3.3.1
- What to do
- If your site has an affected version, update Content Blocks (Custom Post Widget) to version 3.3.1 or newer.
- Official ID
- CVE-2024-3564
- Report title
- Content Blocks (Custom Post Widget) <= 3.3.0 - Authenticated (Contributor+) Local File Inclusion via Shortcode
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.3.0) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.0
- Fixed in
- 3.3.1
- What to do
- If your site has an affected version, update Content Blocks (Custom Post Widget) to version 3.3.1 or newer.
- Official ID
- CVE-2024-34566
- Report title
- Content Blocks (Custom Post Widget) <= 3.3.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)