Custom Twitter Feeds: known security problems
9 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 9 known security problems on this page. Each one has a fixed version. Updating to version 2.9.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.8.0
- Fixed in
- 2.9.0
- What to do
- If your site has an affected version, update Custom Twitter Feeds to version 2.9.0 or newer.
- Official ID
- CVE-2026-84909
- Report title
- Custom Twitter Feeds <= 2.8.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'buttoncolor' Shortcode Attribute
- First reported
- Sources
- Wordfence, seen
A stranger could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.5.4
- Fixed in
- 2.5.5
- What to do
- If your site has an affected version, update Custom Twitter Feeds to version 2.5.5 or newer.
- Official ID
- CVE-2026-6177
- Report title
- Custom Twitter Feeds <= 2.5.4 - Unauthenticated Stored Cross-Site Scripting via Cached Tweet Text
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 2.2.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.5
- Fixed in
- 2.3.0
- What to do
- If your site has an affected version, update Custom Twitter Feeds to version 2.3.0 or newer.
- Official ID
- CVE-2025-1314
- Report title
- Custom Twitter Feeds <= 2.2.5 - Cross-Site Request Forgery to Cache Reset via ctf_clear_cache_admin Function
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 2.2.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.3
- Fixed in
- 2.2.4
- What to do
- If your site has an affected version, update Custom Twitter Feeds to version 2.2.4 or newer.
- Official ID
- CVE-2024-49685
- Report title
- Custom Twitter Feeds (Tweets Widget) <= 2.2.3 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.2.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.2
- Fixed in
- 2.2.3
- What to do
- If your site has an affected version, update Custom Twitter Feeds to version 2.2.3 or newer.
- Official ID
- CVE-2024-8983
- Report title
- Custom Twitter Feeds – A Tweets Widget or X Feed Widget <= 2.2.2 - Authenticated (Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 2.2.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.1
- Fixed in
- 2.2.2
- What to do
- If your site has an affected version, update Custom Twitter Feeds to version 2.2.2 or newer.
- Official ID
- CVE-2024-0379
- Report title
- Custom Twitter Feeds – A Tweets Widget or X Feed Widget <= 2.2.1 - Cross-Site Request Forgery to Plugin Options Update
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 2.1.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.2
- Fixed in
- 2.2
- What to do
- If your site has an affected version, update Custom Twitter Feeds to version 2.2 or newer.
- Official ID
- CVE-2023-52136
- Report title
- Custom Twitter Feeds (Tweets Widget) <= 2.1.2 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (before 2.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.0
- Fixed in
- 2.0
- What to do
- If your site has an affected version, update Custom Twitter Feeds to version 2.0 or newer.
- Official ID
- CVE-2022-33974
- Report title
- Custom Twitter Feeds (Tweets Widget) <= 1.8.4 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.8.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.8.1
- Fixed in
- 1.8.2
- What to do
- If your site has an affected version, update Custom Twitter Feeds to version 1.8.2 or newer.
- Report title
- Smash Balloon Plugins (Various Versions) - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)