Defender Security: known security problems
8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 8 known security problems on this page. Each one has a fixed version. Updating to version 6.2.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone who already has an admin account could run their own code on your site and take it over
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 6.2.0
- Fixed in
- 6.2.0
- What to do
- If your site has an affected version, update Defender Security to version 6.2.0 or newer.
- Official ID
- CVE-2026-19225
- Report title
- Defender Security – Malware Scanner, Login Security & Firewall < 6.2.0 - Authenticated (Administrator+) Remote Code Execution
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.7.2
- Fixed in
- 4.7.3
- What to do
- If your site has an affected version, update Defender Security to version 4.7.3 or newer.
- Official ID
- CVE-2024-37444
- Report title
- Defender Security <= 4.7.2 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site (up to and including 4.4.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.4.1
- Fixed in
- 4.4.2
- What to do
- If your site has an affected version, update Defender Security to version 4.4.2 or newer.
- Official ID
- CVE-2024-25595
- Report title
- Defender Security <= 4.4.1 - IP Address Spoofing
- First reported
- Sources
- Wordfence, seen
Someone could see private information they should not see
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.1.0
- Fixed in
- 4.2.0
- What to do
- If your site has an affected version, update Defender Security to version 4.2.0 or newer.
- Official ID
- CVE-2023-51490
- Report title
- Defender Security <= 4.1.0 - Sensitive Information Exposure via Log File
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site (up to and including 4.2.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.2.0
- Fixed in
- 4.2.1
- What to do
- If your site has an affected version, update Defender Security to version 4.2.1 or newer.
- Official ID
- CVE-2023-47189
- Report title
- Defender Security <= 4.2.0 - Masked Login Area Security Feature Bypass
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site (up to and including 4.0.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.0.2
- Fixed in
- 4.1.0
- What to do
- If your site has an affected version, update Defender Security to version 4.1.0 or newer.
- Official ID
- CVE-2023-5089
- Report title
- Defender Security <= 4.0.2 - Hide Login Page Feature Protection Bypass
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site (up to and including 3.3.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.2
- Fixed in
- 3.3.3
- What to do
- If your site has an affected version, update Defender Security to version 3.3.3 or newer.
- Official ID
- CVE-2022-44581
- Report title
- Defender Security <= 3.3.2 - Sensitive Information Disclosure
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.6
- Fixed in
- 2.4.6.1
- What to do
- If your site has an affected version, update Defender Security to version 2.4.6.1 or newer.
- Official ID
- CVE-2021-4425
- Report title
- Defender Security <= 2.4.6 - Cross-Site Request Forgery Bypass
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)