EN ES
Start free

Yoast Duplicate Post: known security problems

5 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 5 known security problems on this page. Each one has a fixed version. Updating to version 4.6 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone with a contributor account on your site could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.5
Fixed in
4.6
What to do
If your site has an affected version, update Yoast Duplicate Post to version 4.6 or newer.
Official ID
CVE-2026-1217
Report title
Yoast Duplicate Post <= 4.5 - Authenticated (Contributor+) Missing Authorization to Arbitrary Post Duplication and Overwrite
First reported
Sources
This week

Someone who already has an admin account could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.2.3
Fixed in
3.2.4
What to do
If your site has an affected version, update Yoast Duplicate Post to version 3.2.4 or newer.
Official ID
CVE-2019-25314
Report title
Duplicate Post <= 3.2.3 - Authenticated (Administrator+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (before 3.2.4)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 3.2.4
Fixed in
3.2.4
What to do
If your site has an affected version, update Yoast Duplicate Post to version 3.2.4 or newer.
Official ID
CVE-2019-25314
Report title
Yoast Duplicate Post <= 3.2.3 - Authenticated (Admin+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could read or change the data in your site’s database

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.5
Fixed in
2.6
What to do
If your site has an affected version, update Yoast Duplicate Post to version 2.6 or newer.
Official ID
CVE-2014-10379
Report title
Yoast Duplicate Post <= 2.5 - SQL Injection
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 2.6)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.6
Fixed in
3.0
What to do
If your site has an affected version, update Yoast Duplicate Post to version 3.0 or newer.
Official ID
CVE-2014-10378
Report title
Yoast Duplicate Post <= 2.6 - Cross-Site Scripting
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)