GTM4WP – A Google Tag Manager (GTM) plugin for WordPress: known security problems
4 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 4 known security problems on this page. Each one has a fixed version. Updating to version 1.22.4 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.22.3
- Fixed in
- 1.22.4
- What to do
- If your site has an affected version, update GTM4WP – A Google Tag Manager (GTM) plugin for WordPress to version 1.22.4 or newer.
- Official ID
- CVE-2026-16597
- Report title
- GTM4WP <= 1.22.3 - Unauthenticated Stored Cross-Site Scripting via WooCommerce Billing Fields
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.15.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.15.1
- Fixed in
- 1.15.2
- What to do
- If your site has an affected version, update GTM4WP – A Google Tag Manager (GTM) plugin for WordPress to version 1.15.2 or newer.
- Official ID
- CVE-2022-1961
- Report title
- Google Tag Manager for WordPress (GTM4WP) <= 1.15.1 - Stored Cross-Site Scripting via Content Element ID
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.15)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.15
- Fixed in
- 1.15.1
- What to do
- If your site has an affected version, update GTM4WP – A Google Tag Manager (GTM) plugin for WordPress to version 1.15.1 or newer.
- Official ID
- CVE-2022-1707
- Report title
- Google Tag Manager for WordPress <= 1.15 - Reflected Cross-Site Scripting via Site Search
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.15) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.15
- Fixed in
- 1.15.1
- What to do
- If your site has an affected version, update GTM4WP – A Google Tag Manager (GTM) plugin for WordPress to version 1.15.1 or newer.
- Report title
- Google Tag Manager for WordPress <= 1.15 - Cross-Site Scripting via Cloudflare Country Code
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)