EN ES
Start free

Dynamic Widgets: known security problems

6 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 6 known security problems on this page. Each one has a fixed version. Updating to version 1.6.5 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone could trick a logged-in admin into changing settings without knowing

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.6.4
Fixed in
1.6.5
What to do
If your site has an affected version, update Dynamic Widgets to version 1.6.5 or newer.
Official ID
CVE-2024-51669
Report title
Dynamic Widgets <= 1.6.4 - Cross-Site Request Forgery
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 1.5.16)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.5.16
Fixed in
1.6
What to do
If your site has an affected version, update Dynamic Widgets to version 1.6 or newer.
Official ID
CVE-2021-24933
Report title
Dynamic Widgets <= 1.5.16 - Reflected Cross-Site Scripting
First reported
Sources
This week

Someone could read or change the data in your site’s database

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.5.10
Fixed in
1.5.11
What to do
If your site has an affected version, update Dynamic Widgets to version 1.5.11 or newer.
Official ID
CVE-2015-10100
Report title
Dynamic Widgets <= 1.5.10 - Authenticated SQL Injection
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (before 1.5.11)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 1.5.11
Fixed in
1.5.11
What to do
If your site has an affected version, update Dynamic Widgets to version 1.5.11 or newer.
Official ID
CVE-2015-9437
Report title
Dynamic Widgets <= 1.5.10 - Refletced Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (before 1.5.11) (2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 1.5.11
Fixed in
1.5.11
What to do
If your site has an affected version, update Dynamic Widgets to version 1.5.11 or newer.
Official ID
CVE-2015-9436
Report title
Dynamic Widgets <= 1.5.10 - Cross-Site Scripting
First reported
Sources
This week

Someone could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.5.1
Fixed in
1.5.2
What to do
If your site has an affected version, update Dynamic Widgets to version 1.5.2 or newer.
Report title
Dynamic Widgets <= 1.5.1 - Cross Site Scripting
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)