Easy Accordion: known security problems
5 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 5 known security problems on this page. Each one has a fixed version. Updating to version 3.1.9 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.1.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.1.8
- Fixed in
- 3.1.9
- What to do
- If your site has an affected version, update Easy Accordion to version 3.1.9 or newer.
- Official ID
- CVE-2026-18988
- Report title
- Easy Accordion <= 3.1.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'accordionTitleTag' Block Attribute
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.1.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.1.6
- Fixed in
- 3.1.7
- What to do
- If your site has an affected version, update Easy Accordion to version 3.1.7 or newer.
- Official ID
- CVE-2026-15652
- Report title
- Easy Accordion <= 3.1.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'align' Block Attribute
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.3.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.3.4
- Fixed in
- 2.3.5
- What to do
- If your site has an affected version, update Easy Accordion to version 2.3.5 or newer.
- Official ID
- CVE-2024-1363
- Report title
- Easy Accordion – Best Accordion FAQ Plugin for WordPress <= 2.3.4 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.1.20)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.20
- Fixed in
- 2.2.0
- What to do
- If your site has an affected version, update Easy Accordion to version 2.2.0 or newer.
- Official ID
- CVE-2022-4487
- Report title
- Easy Accordion <= 2.1.20 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.21
- Fixed in
- 2.0.22
- What to do
- If your site has an affected version, update Easy Accordion to version 2.0.22 or newer.
- Official ID
- CVE-2021-24576
- Report title
- Easy Accordion <= 2.0.21 - Authenticated Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)