Echo Knowledge Base: known security problems
4 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 4 known security problems on this page. Each one has a fixed version. Updating to version 17.311.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 17.214.0
- Fixed in
- 17.311.0
- What to do
- If your site has an affected version, update Echo Knowledge Base to version 17.311.0 or newer.
- Official ID
- CVE-2026-101935
- Report title
- Echo Knowledge Base <= 17.214.0 - Reflected Cross-Site Scripting via 'new_kb_config' Parameter
- First reported
- Sources
- Wordfence, seen
A stranger could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 17.211.0
- Fixed in
- 17.212.0
- What to do
- If your site has an affected version, update Echo Knowledge Base to version 17.212.0 or newer.
- Official ID
- CVE-2026-28187
- Report title
- Knowledge Base for Documentation, FAQs with AI Assistance <= 17.211.0 - Unauthenticated Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 16.011.0
- Fixed in
- 16.20.0
- What to do
- If your site has an affected version, update Echo Knowledge Base to version 16.20.0 or newer.
- Official ID
- CVE-2026-25402
- Report title
- Echo Knowledge Base – Documentation, FAQs, AI Chat & AI Search <= 16.011.0 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
A stranger could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 11.30.2
- Fixed in
- 11.31.0
- What to do
- If your site has an affected version, update Echo Knowledge Base to version 11.31.0 or newer.
- Official ID
- CVE-2024-24842
- Report title
- Knowledge Base for Documentation, FAQs with AI Assistance <= 11.30.2 - Unauthenticated PHP Object Injection in is_article_recently_viewed
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)