EleSpare – News, Magazine and Blog Addons for Elementor: known security problems
3 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 3 known security problems on this page. Each one has a fixed version. Updating to version 3.3.4 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.2
- Fixed in
- 3.3.4
- What to do
- If your site has an affected version, update EleSpare – News, Magazine and Blog Addons for Elementor to version 3.3.4 or newer.
- Official ID
- CVE-2024-13362
- Report title
- Freemius <= 2.10.1 - Reflected DOM-Based Cross-Site Scripting via url Parameter
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.1.2
- Fixed in
- 3.2.0
- What to do
- If your site has an affected version, update EleSpare – News, Magazine and Blog Addons for Elementor to version 3.2.0 or newer.
- Official ID
- CVE-2024-4615
- Report title
- Elespare – Blog, Magazine and Newspaper Addons for Elementor with Templates, Widgets, Kits, and Header/Footer Builder. One Click Import: No Coding Required! <= 3.1.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Horizontal Nav Menu Widget
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.2
- Fixed in
- 2.1.3
- What to do
- If your site has an affected version, update EleSpare – News, Magazine and Blog Addons for Elementor to version 2.1.3 or newer.
- Official ID
- CVE-2024-0900
- Report title
- Elespare – Build Your Blog, News & Magazine Websites with Expert-Designed Template Kits. One Click Import: No Coding Skills Required! <= 2.1.2 - Missing Authorization to Subscriber+ Arbitrary Post Creation
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)