EN ES
Start free

Float menu – awesome floating side menu: known security problems

5 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 5 known security problems on this page. Each one has a fixed version. Updating to version 6.1.3 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone could trick a logged-in admin into changing settings without knowing (up to and including 6.1.2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 6.1.2
Fixed in
6.1.3
What to do
If your site has an affected version, update Float menu – awesome floating side menu to version 6.1.3 or newer.
Official ID
CVE-2025-30912
Report title
Float menu <= 6.1.2 - Cross-Site Request Forgery to Settings Update
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing (up to and including 6.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 6.0
Fixed in
6.0.1
What to do
If your site has an affected version, update Float menu – awesome floating side menu to version 6.0.1 or newer.
Official ID
CVE-2024-2405
Report title
Float menu – awesome floating side menu <= 6.0 - Cross-Site Request Forgery to Menu Deletion
First reported
Sources
This week

Someone who already has an admin account could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 5.0.2
Fixed in
5.0.3
What to do
If your site has an affected version, update Float menu – awesome floating side menu to version 5.0.3 or newer.
Official ID
CVE-2023-3225
Report title
Float menu <= 5.0.2 - Authenticated(Administrator+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 5.0.1
Fixed in
5.0.2
What to do
If your site has an affected version, update Float menu – awesome floating side menu to version 5.0.2 or newer.
Official ID
CVE-2023-2362
Report title
Multiple Wow-Company Plugins (Various Versions) -- Reflected Cross-Site Scripting via 'page' parameter
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing (up to and including 4.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.3
Fixed in
4.3.1
What to do
If your site has an affected version, update Float menu – awesome floating side menu to version 4.3.1 or newer.
Official ID
CVE-2022-0313
Report title
Float Menu <= 4.3 - Arbitrary Menu Deletion via Cross-Site Request Forgery
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)