FluentAuth – Login Security, Two-Factor Authentication, Passkeys & Social Login: known security problems
3 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 3 known security problems on this page. Each one has a fixed version. Updating to version 3.0.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.2
- Fixed in
- 3.0.0
- What to do
- If your site has an affected version, update FluentAuth – Login Security, Two-Factor Authentication, Passkeys & Social Login to version 3.0.0 or newer.
- Official ID
- CVE-2026-78296
- Report title
- FluentAuth – Login Security, Two-Factor Authentication, Passkeys & Social Login <= 2.1.2 - Unauthenticated Email Verification Bypass
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.3
- Fixed in
- 2.1.0
- What to do
- If your site has an affected version, update FluentAuth – Login Security, Two-Factor Authentication, Passkeys & Social Login to version 2.1.0 or newer.
- Official ID
- CVE-2025-13728
- Report title
- FluentAuth - Auth Security Plugin <= 2.0.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'fluent_auth_reset_password' Shortcode
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.0.1
- Fixed in
- 1.0.2
- What to do
- If your site has an affected version, update FluentAuth – Login Security, Two-Factor Authentication, Passkeys & Social Login to version 1.0.2 or newer.
- Official ID
- CVE-2022-4746
- Report title
- FluentAuth <= 1.0.1 - IP Spoofing to Protection Mechanism Bypass
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)