EN ES
Start free

FluentSMTP – WP Mail SMTP Plugin with Amazon SES, SendGrid, Mailgun, Postmark, Cloudflare, toSend, Gmail and Any SMTP: known security problems

6 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 6 known security problems on this page. Each one has a fixed version. Updating to version 2.3.0 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

A stranger could plant harmful code that runs for your visitors or admins (up to and including 2.2.95)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.95
Fixed in
2.3.0
What to do
If your site has an affected version, update FluentSMTP – WP Mail SMTP Plugin with Amazon SES, SendGrid, Mailgun, Postmark, Cloudflare, toSend, Gmail and Any SMTP to version 2.3.0 or newer.
Official ID
CVE-2026-16636
Report title
FluentSMTP <= 2.2.95 - Unauthenticated Stored Cross-Site Scripting via Recipient Display Name (to.name) in Email Logs
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.80
Fixed in
2.2.81
What to do
If your site has an affected version, update FluentSMTP – WP Mail SMTP Plugin with Amazon SES, SendGrid, Mailgun, Postmark, Cloudflare, toSend, Gmail and Any SMTP to version 2.2.81 or newer.
Official ID
CVE-2025-24739
Report title
FluentSMTP <= 2.2.80 - Cross-Site Request Forgery
First reported
Sources
This week

A stranger could in some setups, take over your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.82
Fixed in
2.2.83
What to do
If your site has an affected version, update FluentSMTP – WP Mail SMTP Plugin with Amazon SES, SendGrid, Mailgun, Postmark, Cloudflare, toSend, Gmail and Any SMTP to version 2.2.83 or newer.
Official ID
CVE-2024-9511
Report title
FluentSMTP – WP SMTP Plugin with Amazon SES, SendGrid, MailGun, Postmark, Google and Any SMTP Provider <= 2.2.82 - Unauthenticated PHP Object Injection
First reported
Sources
This week

A stranger could plant harmful code that runs for your visitors or admins (up to and including 2.2.4)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.4
Fixed in
2.2.5
What to do
If your site has an affected version, update FluentSMTP – WP Mail SMTP Plugin with Amazon SES, SendGrid, Mailgun, Postmark, Cloudflare, toSend, Gmail and Any SMTP to version 2.2.5 or newer.
Official ID
CVE-2023-3087
Report title
FluentSMTP <= 2.2.4 - Unauthenticated Stored Cross-Site Scripting via Email Subject
First reported
Sources
This week

Someone with an author account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.2
Fixed in
2.2.3
What to do
If your site has an affected version, update FluentSMTP – WP Mail SMTP Plugin with Amazon SES, SendGrid, Mailgun, Postmark, Cloudflare, toSend, Gmail and Any SMTP to version 2.2.3 or newer.
Official ID
CVE-2023-0219
Report title
FluentSMTP <= 2.2.2 - Authenticated (Author+) Stored Cross-Site Scripting via Email Logs
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 2.0.1
Fixed in
2.0.1
What to do
If your site has an affected version, update FluentSMTP – WP Mail SMTP Plugin with Amazon SES, SendGrid, Mailgun, Postmark, Cloudflare, toSend, Gmail and Any SMTP to version 2.0.1 or newer.
Official ID
CVE-2021-24528
Report title
FluentSMTP <= 2.0.0 - Authenticated (Admin+) Stored Cross-Site Scripting
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)