Lightbox & Modal Popup WordPress Plugin – FooBox: known security problems
7 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 7 known security problems on this page. Each one has a fixed version. Updating to version 2.7.35 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.7.33)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.7.33
- Fixed in
- 2.7.34
- What to do
- If your site has an affected version, update Lightbox & Modal Popup WordPress Plugin – FooBox to version 2.7.34 or newer.
- Official ID
- CVE-2024-13362
- Report title
- Freemius <= 2.10.1 - Reflected DOM-Based Cross-Site Scripting via url Parameter
- First reported
- Sources
- Wordfence, seen
Someone with an author account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.7.34)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.7.34
- Fixed in
- 2.7.35
- What to do
- If your site has an affected version, update Lightbox & Modal Popup WordPress Plugin – FooBox to version 2.7.35 or newer.
- Official ID
- CVE-2025-5537
- Report title
- Lightbox & Modal Popup WordPress Plugin – FooBox <= 2.7.34 - Authenticated (Author+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with an author account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.7.33)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.7.33
- Fixed in
- 2.7.34
- What to do
- If your site has an affected version, update Lightbox & Modal Popup WordPress Plugin – FooBox to version 2.7.34 or newer.
- Official ID
- CVE-2025-32139
- Report title
- FooBox Image Lightbox <= 2.7.33 - Authenticated (Author+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.7.28
- Fixed in
- 2.7.32
- What to do
- If your site has an affected version, update Lightbox & Modal Popup WordPress Plugin – FooBox to version 2.7.32 or newer.
- Official ID
- CVE-2024-5668
- Report title
- Lightbox & Modal Popup WordPress Plugin – FooBox <= 2.7.28 - Authenticated (Contributor+) Stored DOM-Based Cross-Site Scripting via HTML Data Attributes
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.7.27)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.7.27
- Fixed in
- 2.7.28
- What to do
- If your site has an affected version, update Lightbox & Modal Popup WordPress Plugin – FooBox to version 2.7.28 or newer.
- Official ID
- CVE-2024-3276
- Report title
- Lightbox & Modal Popup WordPress Plugin – FooBox (Free and Premium) <= 2.7.27 - Authenticated (Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (before 2.7.17)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.7.17
- Fixed in
- 2.7.17
- What to do
- If your site has an affected version, update Lightbox & Modal Popup WordPress Plugin – FooBox to version 2.7.17 or newer.
- Official ID
- CVE-2022-4974
- Report title
- Freemius SDK <= 2.4.2 - Missing Authorization Checks
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (before 2.6.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.6.4
- Fixed in
- 2.6.4
- What to do
- If your site has an affected version, update Lightbox & Modal Popup WordPress Plugin – FooBox to version 2.6.4 or newer.
- Report title
- Freemius SDK <= 2.2.3 - Missing Authorization to Arbitrary Options Update
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)