EN ES
Start free

Easy Google Maps by Supsystic: known security problems

10 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 10 known security problems on this page. Each one has a fixed version. Updating to version 1.15.1 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

A stranger could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.14.6
Fixed in
1.15.1
What to do
If your site has an affected version, update Easy Google Maps by Supsystic to version 1.15.1 or newer.
Official ID
CVE-2026-102395
Report title
Easy Google Maps <= 1.14.6 - Unauthenticated Stored Cross-Site Scripting
First reported
Sources
This week

A stranger could in some setups, take over your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.13.0
Fixed in
1.14.0
What to do
If your site has an affected version, update Easy Google Maps by Supsystic to version 1.14.0 or newer.
Official ID
CVE-2026-73366
Report title
Easy Google Maps <= 1.13.0 - Unauthenticated PHP Object Injection
First reported
Sources
This week

A stranger could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 1.14.2
Fixed in
1.14.2
What to do
If your site has an affected version, update Easy Google Maps by Supsystic to version 1.14.2 or newer.
Official ID
CVE-2026-73367
Report title
Easy Google Maps < 1.14.2 - Unauthenticated Arbitrary Remote Script Inclusion
First reported
Sources
This week

Someone with an author account on your site could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.11.18
Fixed in
1.11.19
What to do
If your site has an affected version, update Easy Google Maps by Supsystic to version 1.11.19 or newer.
Official ID
CVE-2025-32138
Report title
Easy Google Maps <= 1.11.18 - Authenticated (Author+) XML Entity Injection
First reported
Sources
This week

Someone with an author account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.11.15
Fixed in
1.11.16
What to do
If your site has an affected version, update Easy Google Maps by Supsystic to version 1.11.16 or newer.
Official ID
CVE-2024-5219
Report title
Easy Google Maps <= 1.11.15 - Authenticated (Author+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing (up to and including 1.11.11)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.11.11
Fixed in
1.11.12
What to do
If your site has an affected version, update Easy Google Maps by Supsystic to version 1.11.12 or newer.
Official ID
CVE-2024-31269
Report title
Easy Google Maps <= 1.11.11 - Cross-Site Request Forgery
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing (up to and including 1.11.7)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.11.7
Fixed in
1.11.8
What to do
If your site has an affected version, update Easy Google Maps by Supsystic to version 1.11.8 or newer.
Official ID
CVE-2023-2526
Report title
Easy Google Maps <= 1.11.7 - Cross-Site Request Forgery via AJAX action
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing (up to and including 1.11.7) (2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.11.7
Fixed in
1.11.8
What to do
If your site has an affected version, update Easy Google Maps by Supsystic to version 1.11.8 or newer.
Official ID
CVE-2023-33926
Report title
Easy Google Maps <= 1.11.7 - Cross-Site Request Forgery
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 1.9.31)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.9.31
Fixed in
1.9.32
What to do
If your site has an affected version, update Easy Google Maps by Supsystic to version 1.9.32 or newer.
Official ID
CVE-2021-46780
Report title
Easy Google Maps <= 1.9.31 - Reflected Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 1.9.33)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.9.33
Fixed in
1.10.1
What to do
If your site has an affected version, update Easy Google Maps by Supsystic to version 1.10.1 or newer.
Official ID
CVE-2021-39346
Report title
Google Maps Easy <= 1.9.33 - Stored Cross-Site Scripting
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)