Anti-Malware Security and Brute-Force Firewall: known security problems
11 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 11 known security problems on this page. Each one has a fixed version. Updating to version 4.23.90 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.23.89
- Fixed in
- 4.23.90
- What to do
- If your site has an affected version, update Anti-Malware Security and Brute-Force Firewall to version 4.23.90 or newer.
- Official ID
- CVE-2026-57691
- Report title
- Anti-Malware Security and Brute-Force Firewall <= 4.23.89 - Unauthenticated Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.23.87
- Fixed in
- 4.23.88
- What to do
- If your site has an affected version, update Anti-Malware Security and Brute-Force Firewall to version 4.23.88 or newer.
- Official ID
- CVE-2026-39478
- Report title
- Anti-Malware Security and Brute-Force Firewall <= 4.23.87 - Authenticated (Contributor+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.23.81
- Fixed in
- 4.23.83
- What to do
- If your site has an affected version, update Anti-Malware Security and Brute-Force Firewall to version 4.23.83 or newer.
- Official ID
- CVE-2025-11705
- Report title
- Anti-Malware Security and Brute-Force Firewall <= 4.23.81 - Missing Authorization to Authenticated (Subscriber+) Arbitrary File Read
- First reported
- Sources
- Wordfence, seen
A stranger could run their own code on your site and take it over
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.21.96
- Fixed in
- 4.23.56
- What to do
- If your site has an affected version, update Anti-Malware Security and Brute-Force Firewall to version 4.23.56 or newer.
- Official ID
- CVE-2024-22144
- Report title
- Anti-Malware Security and Brute-Force Firewall <= 4.21.96 - Unauthenticated Remote Code Execution
- First reported
- Sources
- Wordfence, seen
Someone could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.21.85
- Fixed in
- 4.21.86
- What to do
- If your site has an affected version, update Anti-Malware Security and Brute-Force Firewall to version 4.21.86 or newer.
- Official ID
- CVE-2022-4327
- Report title
- Anti-Malware Security and Brute-Force Firewall <= 4.21.85 - Authenticated (Admin+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 4.20.96)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.20.96
- Fixed in
- 4.20.96
- What to do
- If your site has an affected version, update Anti-Malware Security and Brute-Force Firewall to version 4.20.96 or newer.
- Official ID
- CVE-2022-0953
- Report title
- Anti-Malware Security and Brute-Force Firewall <= 4.20.95 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 4.21.74)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.21.74
- Fixed in
- 4.21.83
- What to do
- If your site has an affected version, update Anti-Malware Security and Brute-Force Firewall to version 4.21.83 or newer.
- Official ID
- CVE-2022-2599
- Report title
- Anti-Malware Security and Brute-Force Firewall <= 4.21.74 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 4.20.94)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.20.94
- Fixed in
- 4.20.94
- What to do
- If your site has an affected version, update Anti-Malware Security and Brute-Force Firewall to version 4.20.94 or newer.
- Official ID
- CVE-2021-25101
- Report title
- Anti-Malware Security and Brute-Force Firewall <= 4.20.93 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 4.15.17)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.15.17
- Fixed in
- 4.16.18
- What to do
- If your site has an affected version, update Anti-Malware Security and Brute-Force Firewall to version 4.16.18 or newer.
- Report title
- Anti-Malware Security and Brute-Force Firewall <= 4.15.17 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.15.23
- Fixed in
- 4.15.23
- What to do
- If your site has an affected version, update Anti-Malware Security and Brute-Force Firewall to version 4.15.23 or newer.
- Report title
- Anti-Malware Security and Brute-Force Firewall <= 4.15.22 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 4.15.23)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.15.23
- Fixed in
- 4.15.23
- What to do
- If your site has an affected version, update Anti-Malware Security and Brute-Force Firewall to version 4.15.23 or newer.
- Report title
- Anti-Malware Security and Brute-Force Firewall <= 4.15.22 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)