Translate WordPress with GTranslate: known security problems
8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 8 known security problems on this page. Each one has a fixed version. Updating to version 5.0.1 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.0.0
- Fixed in
- 5.0.1
- What to do
- If your site has an affected version, update Translate WordPress with GTranslate to version 5.0.1 or newer.
- Official ID
- CVE-2026-86604
- Report title
- GTranslate <= 5.0.0 - Unauthenticated Arbitrary Shortcode Execution
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could plant harmful code that runs for your visitors or admins (before 3.0.10)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 3.0.10
- Fixed in
- 3.0.10
- What to do
- If your site has an affected version, update Translate WordPress with GTranslate to version 3.0.10 or newer.
- Official ID
- CVE-2025-15695
- Report title
- Translate WordPress with GTranslate < 3.0.10 - Authenticated (Administrator+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could plant harmful code that runs for your visitors or admins (before 3.0.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 3.0.4
- Fixed in
- 3.0.4
- What to do
- If your site has an affected version, update Translate WordPress with GTranslate to version 3.0.4 or newer.
- Official ID
- CVE-2023-4502
- Report title
- GTranslate <= 3.0.3 - Authenticated (Administrator+) Cross-Site Scripting via Multiple Parameters
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.9.9
- Fixed in
- 2.9.9
- What to do
- If your site has an affected version, update Translate WordPress with GTranslate to version 2.9.9 or newer.
- Official ID
- CVE-2022-0770
- Report title
- Translate WordPress with GTranslate <= 2.9.8 & Translate WordPress – Google Language Translator <= 6.0.13 - Missing Authorization to Sensitive Information Disclosure
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 2.9.7)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.9.7
- Fixed in
- 2.9.7
- What to do
- If your site has an affected version, update Translate WordPress with GTranslate to version 2.9.7 or newer.
- Official ID
- CVE-2021-25103
- Report title
- Translate WordPress with GTranslate <= 2.9.6 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 2.8.65)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.8.65
- Fixed in
- 2.8.65
- What to do
- If your site has an affected version, update Translate WordPress with GTranslate to version 2.8.65 or newer.
- Official ID
- CVE-2021-34630
- Report title
- GTranslate Pro and GTranslate Enterprise <= 2.8.64 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.8.51
- Fixed in
- 2.8.52
- What to do
- If your site has an affected version, update Translate WordPress with GTranslate to version 2.8.52 or newer.
- Official ID
- CVE-2020-11930
- Report title
- GTranslate <= 2.8.51 - Reflected Cross Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could send your visitors from your site to a harmful site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.8.11
- Fixed in
- 2.8.11
- What to do
- If your site has an affected version, update Translate WordPress with GTranslate to version 2.8.11 or newer.
- Report title
- Translate WordPress with GTranslate <= 2.8.10 - Open Redirect
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)