EN ES
Start free

Gutenberg: known security problems

6 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 6 known security problems on this page. Each one has a fixed version. Updating to version 21.9.0 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 21.8.2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 21.8.2
Fixed in
21.9.0
What to do
If your site has an affected version, update Gutenberg to version 21.9.0 or newer.
Official ID
CVE-2025-64354
Report title
Gutenberg <= 21.8.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 18.6.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 18.6.0
Fixed in
18.6.1
What to do
If your site has an affected version, update Gutenberg to version 18.6.1 or newer.
Official ID
CVE-2024-31111
Report title
WordPress Core < 6.5.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Template Part Block
First reported
Sources
This week

A stranger could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • From 12.9.0 up to and including 18.0.0
Fixed in
18.01
What to do
If your site has an affected version, update Gutenberg to version 18.01 or newer.
Report title
Gutenberg 12.9.0 - 18.0.0 - Unauthenticated & Authenticated (Contributor+) Stored Cross-Site Scripting via Avatar Block
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 16.8.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 16.8.0
Fixed in
16.8.1
What to do
If your site has an affected version, update Gutenberg to version 16.8.1 or newer.
Official ID
CVE-2023-38000
Report title
WordPress Core 5.9-6.3.1 - Authenticated(Contributor+) Stored Cross-Site Scripting via Navigation Attributes
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 14.3.0
Fixed in
14.3.1
What to do
If your site has an affected version, update Gutenberg to version 14.3.1 or newer.
Official ID
CVE-2022-43500
Report title
WordPress Core < 6.0.3 & Gutenberg < 14.3.1 - Authenticated Cross-Site Scripting in Various Blocks
First reported
Sources
This week

Someone could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 12.7.2
Fixed in
12.7.2
What to do
If your site has an affected version, update Gutenberg to version 12.7.2 or newer.
Report title
WordPress Core < 5.9.2 & Gutenberg < 12.7.2 - Prototype Pollution via Block Editor
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)