EN ES
Start free

GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor: known security problems

8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 8 known security problems on this page. Each one has a fixed version. Updating to version 2.5.1 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.4.4)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.4.4
Fixed in
2.4.5
What to do
If your site has an affected version, update GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor to version 2.4.5 or newer.
Official ID
CVE-2026-2573
Report title
GutenKit <= 2.4.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'postBodyCss'
First reported
Sources
This week

Someone with a contributor account on your site could use it to harm your site (up to and including 2.5.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.5.0
Fixed in
2.5.1
What to do
If your site has an affected version, update GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor to version 2.5.1 or newer.
Official ID
CVE-2026-19698
Report title
GutenKit <= 2.5.0 - Authenticated (Contributor+) Arbitrary CSS Injection
First reported
Sources
This week

Someone with an author account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 2.5.0
Fixed in
2.5.0
What to do
If your site has an affected version, update GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor to version 2.5.0 or newer.
Official ID
CVE-2026-19697
Report title
GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor < 2.5.0 - Authenticated (Author+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could use it to harm your site (up to and including 2.4.15)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.4.15
Fixed in
2.5.0
What to do
If your site has an affected version, update GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor to version 2.5.0 or newer.
Official ID
CVE-2026-19699
Report title
GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor <= 2.4.15 - Authenticated (Contributor+) Information Exposure
First reported
Sources
This week

A stranger could see private information they should not see

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.4.12
Fixed in
2.4.13
What to do
If your site has an affected version, update GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor to version 2.4.13 or newer.
Official ID
CVE-2026-15827
Report title
GutenKit <= 2.4.12 - Missing Authorization to Unauthenticated Sensitive Information Exposure via Mailchimp REST Endpoints
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.4.2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.4.2
Fixed in
2.4.3
What to do
If your site has an affected version, update GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor to version 2.4.3 or newer.
Official ID
CVE-2025-57900
Report title
GutenKit <= 2.4.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.2.2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.2
Fixed in
2.2.3
What to do
If your site has an affected version, update GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor to version 2.2.3 or newer.
Official ID
CVE-2025-46253
Report title
GutenKit <= 2.2.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

A stranger could run their own code on your site and take it over

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.1.0
Fixed in
2.1.1
What to do
If your site has an affected version, update GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor to version 2.1.1 or newer.
Official ID
CVE-2024-9234
Report title
GutenKit <= 2.1.0 - Unauthenticated Arbitrary File Upload
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)