Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor: known security problems
10 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 10 known security problems on this page. 9 of them have a fixed version. Updating to version 4.0.6 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Anyone with an account on your site, even a basic one could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.0.6
- Fixed in
- 4.0.6
- What to do
- If your site has an affected version, update Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor to version 4.0.6 or newer.
- Official ID
- CVE-2026-16983
- Report title
- Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor < 4.0.6 - Authenticated (Subscriber+) Password-Protected Post Password Disclosure
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.5.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.5.5
- Fixed in
- 3.5.6
- What to do
- If your site has an affected version, update Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor to version 3.5.6 or newer.
- Official ID
- CVE-2026-2951
- Report title
- Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor <= 3.5.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Gutentor Block HTML
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.5.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.5.2
- Fixed in
- 3.5.3
- What to do
- If your site has an affected version, update Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor to version 3.5.3 or newer.
- Official ID
- CVE-2025-58680
- Report title
- Gutentor <= 3.5.2 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.5.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.5.5
- Fixed in
- 3.5.6
- What to do
- If your site has an affected version, update Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor to version 3.5.6 or newer.
- Official ID
- CVE-2025-58783
- Report title
- Gutentor <= 3.5.5 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.4.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.4.8
- Fixed in
- 3.4.9
- What to do
- If your site has an affected version, update Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor to version 3.4.9 or newer.
- Official ID
- CVE-2025-4685
- Report title
- Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor <= 3.4.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Widgets
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.4.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.4.9
- Fixed in
- No fixed version yet
- What to do
- There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
- Official ID
- CVE-2024-5647
- Report title
- Multiple Plugins <= (Various Versions) - Authenticated (Contributor+) Stored DOM-Based Cross-Site Scripting via Magnific Popups JavaScript Library
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.4.6
- Fixed in
- 3.4.7
- What to do
- If your site has an affected version, update Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor to version 3.4.7 or newer.
- Official ID
- CVE-2025-1986
- Report title
- Gutentor <= 3.4.6 - Authenticated (Administrator+) SQL Injection
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.4.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.4.3
- Fixed in
- 3.4.4
- What to do
- If your site has an affected version, update Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor to version 3.4.4 or newer.
- Official ID
- CVE-2025-22293
- Report title
- Gutentor <= 3.4.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.3.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.9
- Fixed in
- 3.4.0
- What to do
- If your site has an affected version, update Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor to version 3.4.0 or newer.
- Official ID
- CVE-2024-10178
- Report title
- Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor <= 3.3.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Countdown Widget
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.3.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.5
- Fixed in
- 3.3.6
- What to do
- If your site has an affected version, update Gutentor – Gutenberg Blocks – Page Builder for Gutenberg Editor to version 3.3.6 or newer.
- Official ID
- CVE-2024-43308
- Report title
- Gutentor - Gutenberg Blocks - Page Builder for Gutenberg Editor <= 3.3.5 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)