HTML5 Audio Player: known security problems
8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 8 known security problems on this page. 7 of them have a fixed version. Updating to version 2.5.2 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.8.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.8.8
- Fixed in
- No fixed version yet
- What to do
- There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
- Official ID
- CVE-2026-62039
- Report title
- HTML5 Audio Player – The Ultimate No-Code Podcast, MP3 & Audio Player <= 2.8.8 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.2.27)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.27
- Fixed in
- 2.5.1
- What to do
- If your site has an affected version, update HTML5 Audio Player to version 2.5.1 or newer.
- Official ID
- CVE-2024-13362
- Report title
- Freemius <= 2.10.1 - Reflected DOM-Based Cross-Site Scripting via url Parameter
- First reported
- Sources
- Wordfence, seen
A stranger could make your server visit other addresses on their behalf
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- From 2.4.0 up to and including 2.5.1
- Fixed in
- 2.5.2
- What to do
- If your site has an affected version, update HTML5 Audio Player to version 2.5.2 or newer.
- Official ID
- CVE-2025-13999
- Report title
- HTML5 Audio Player – The Ultimate No-Code Podcast, MP3 & Audio Player 2.4.0 - 2.5.1 - Unauthenticated Server-Side Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.2.28)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.28
- Fixed in
- 2.3.0
- What to do
- If your site has an affected version, update HTML5 Audio Player to version 2.3.0 or newer.
- Official ID
- CVE-2025-39524
- Report title
- Html5 Audio Player <= 2.2.28 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.2.23)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.23
- Fixed in
- 2.2.24
- What to do
- If your site has an affected version, update HTML5 Audio Player to version 2.2.24 or newer.
- Official ID
- CVE-2024-37445
- Report title
- Html5 Audio Player <= 2.2.23 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.2.19)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.19
- Fixed in
- 2.2.22
- What to do
- If your site has an affected version, update HTML5 Audio Player to version 2.2.22 or newer.
- Official ID
- CVE-2024-4398
- Report title
- HTML5 Audio Player- Best WordPress Audio Player Plugin <= 2.2.19 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Widgets
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.1.11)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.11
- Fixed in
- 2.1.12
- What to do
- If your site has an affected version, update HTML5 Audio Player to version 2.1.12 or newer.
- Official ID
- CVE-2023-0170
- Report title
- Html5 Audio Player <= 2.1.11 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.1.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.2
- Fixed in
- 2.1.3
- What to do
- If your site has an affected version, update HTML5 Audio Player to version 2.1.3 or newer.
- Official ID
- CVE-2021-24412
- Report title
- Html5 Audio Player <= 2.1.2 - Contributor+ Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)