HTTP Headers: known security problems
7 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 7 known security problems on this page. 6 of them have a fixed version. Updating to version 1.19.5 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone who already has an admin account could use it to harm your site (up to and including 1.19.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.19.2
- Fixed in
- 1.19.3
- What to do
- If your site has an affected version, update HTTP Headers to version 1.19.3 or newer.
- Official ID
- CVE-2026-4132
- Report title
- HTTP Headers <= 1.19.2 - Authenticated (Administrator+) External Control of File Name or Path to RCE via 'hh_htpasswd_path' and 'hh_www_authenticate_user' Parameters
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could use it to harm your site (up to and including 1.19.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.19.5
- Fixed in
- No fixed version yet
- What to do
- There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
- Official ID
- CVE-2026-2717
- Report title
- HTTP Headers <= 1.19.5 - Authenticated (Administrator+) CRLF Injection via Custom Header Values
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could plant harmful code that runs for your visitors or admins (up to and including 1.19.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.19.4
- Fixed in
- 1.19.5
- What to do
- If your site has an affected version, update HTTP Headers to version 1.19.5 or newer.
- Official ID
- CVE-2026-1379
- Report title
- HTTP Headers <= 1.19.4 - Authenticated (Administrator+) Stored Cross-Site Scripting via 'Custom Headers' Plugin Setting
- First reported
- Sources
- Wordfence, seen
Someone could make your server visit other addresses on their behalf
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.18.11
- Fixed in
- 1.19.0
- What to do
- If your site has an affected version, update HTTP Headers to version 1.19.0 or newer.
- Official ID
- CVE-2023-37978
- Report title
- HTTP Headers <= 1.18.11 - Server-Side Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could plant harmful code that runs for your visitors or admins (up to and including 1.18.11)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.18.11
- Fixed in
- 1.19.0
- What to do
- If your site has an affected version, update HTTP Headers to version 1.19.0 or newer.
- Official ID
- CVE-2023-37874
- Report title
- HTTP Headers <= 1.18.11 - Authenticated (Administrator+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could run their own code on your site and take it over
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.18.10
- Fixed in
- 1.18.11
- What to do
- If your site has an affected version, update HTTP Headers to version 1.18.11 or newer.
- Official ID
- CVE-2023-1208
- Report title
- HTTP Headers <= 1.18.10 - Authenticated(Administrator+) Remote Code Execution
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.18.8
- Fixed in
- 1.18.9
- What to do
- If your site has an affected version, update HTTP Headers to version 1.18.9 or newer.
- Official ID
- CVE-2023-1207
- Report title
- HTTP Headers <= 1.18.8 - Authenticated(Administrator+) SQL Injection
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)