Insert Pages: known security problems
5 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 5 known security problems on this page. Each one has a fixed version. Updating to version 3.11.5 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with an author account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.11.4
- Fixed in
- 3.11.5
- What to do
- If your site has an affected version, update Insert Pages to version 3.11.5 or newer.
- Official ID
- CVE-2026-10089
- Report title
- Insert Pages <= 3.11.4 - Authenticated (Author+) Stored Cross-Site Scripting via Custom Field Keys (Meta Key Names)
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.7.4
- Fixed in
- 3.7.5
- What to do
- If your site has an affected version, update Insert Pages to version 3.7.5 or newer.
- Official ID
- CVE-2022-4483
- Report title
- Insert Pages <= 3.7.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site (up to and including 3.6.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.6.1
- Fixed in
- 3.7.0
- What to do
- If your site has an affected version, update Insert Pages to version 3.7.0 or newer.
- Official ID
- CVE-2021-24851
- Report title
- Insert Pages <= 3.6.1 - Contributor+ Arbitrary Posts/Pages Access
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.6.1
- Fixed in
- 3.7.0
- What to do
- If your site has an affected version, update Insert Pages to version 3.7.0 or newer.
- Official ID
- CVE-2021-24850
- Report title
- Insert Pages <= 3.6.1 - Contributor+ Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site (before 3.2.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 3.2.4
- Fixed in
- 3.2.4
- What to do
- If your site has an affected version, update Insert Pages to version 3.2.4 or newer.
- Official ID
- CVE-2017-18586
- Report title
- Insert Pages < 3.2.4 - Authenticated Directory Traversal
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)