Woody Code Snippets: known security problems
8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 8 known security problems on this page. Each one has a fixed version. Updating to version 2.7.2 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could run their own code on your site and take it over (up to and including 2.7.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.7.1
- Fixed in
- 2.7.2
- What to do
- If your site has an affected version, update Woody Code Snippets to version 2.7.2 or newer.
- Official ID
- CVE-2026-25366
- Report title
- Woody Code Snippets – Insert PHP, CSS, JS, and Header/Footer Scripts <= 2.7.1 - Authenticated (Contributor+) Remote Code Execution
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could run their own code on your site and take it over (up to and including 2.5.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.5.0
- Fixed in
- 2.5.1
- What to do
- If your site has an affected version, update Woody Code Snippets to version 2.5.1 or newer.
- Official ID
- CVE-2024-3105
- Report title
- Woody code snippets – Insert Header Footer Code, AdSense Ads <= 2.5.0 -Authenticated (Contributor+) Remote Code Execution
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.5.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.5.0
- Fixed in
- 2.5.1
- What to do
- If your site has an affected version, update Woody Code Snippets to version 2.5.1 or newer.
- Official ID
- CVE-2024-35751
- Report title
- Woody code snippets – Insert Header Footer Code, AdSense Ads <= 2.5.0 - Authenticated (Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.4.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.5
- Fixed in
- 2.4.6
- What to do
- If your site has an affected version, update Woody Code Snippets to version 2.4.6 or newer.
- Report title
- Woody code snippets <= 2.4.5 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.3.10
- Fixed in
- 2.3.10
- What to do
- If your site has an affected version, update Woody Code Snippets to version 2.3.10 or newer.
- Official ID
- CVE-2020-36759
- Report title
- Woody code snippets <= 2.3.9 - Cross-Site Request Forgery Bypass
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 2.2.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.2.9
- Fixed in
- 2.2.9
- What to do
- If your site has an affected version, update Woody Code Snippets to version 2.2.9 or newer.
- Official ID
- CVE-2019-16289
- Report title
- Woody Ad Snippets <= 2.2.8 - Authenticated Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.5
- Fixed in
- 2.2.6
- What to do
- If your site has an affected version, update Woody Code Snippets to version 2.2.6 or newer.
- Official ID
- CVE-2019-14773
- Report title
- Woody Ad Snippets <= 2.2.5 - Arbitrary Post Deletion
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.2.5
- Fixed in
- 2.2.5
- What to do
- If your site has an affected version, update Woody Code Snippets to version 2.2.5 or newer.
- Official ID
- CVE-2019-15858
- Report title
- Woody Ad Snippets <= 2.2.4 - Missing Authorization to Settings Import
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)