RD Station: known security problems
4 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 4 known security problems on this page. Each one has a fixed version. Updating to version 5.7.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could run their own code on your site and take it over
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.6.0
- Fixed in
- 5.7.0
- What to do
- If your site has an affected version, update RD Station to version 5.7.0 or newer.
- Official ID
- CVE-2026-49774
- Report title
- RD Station <= 5.6.0 - Authenticated (Contributor+) Remote Code Execution
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.3.2
- Fixed in
- 5.4.0
- What to do
- If your site has an affected version, update RD Station to version 5.4.0 or newer.
- Official ID
- CVE-2024-6894
- Report title
- RD Station <= 5.3.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 5.1.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.1.3
- Fixed in
- 5.2.0
- What to do
- If your site has an affected version, update RD Station to version 5.2.0 or newer.
- Official ID
- CVE-2022-38139
- Report title
- RD Station <= 5.1.3 - Cross-Site Request Forgery to Plugin Log Deletion
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 5.2.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.2.0
- Fixed in
- 5.2.1
- What to do
- If your site has an affected version, update RD Station to version 5.2.1 or newer.
- Official ID
- CVE-2022-38139
- Report title
- RD Station <= 5.2.0 - Cross-Site Request Forgery to Plugin Settings Update
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)