Kadence WooCommerce Email Designer: known security problems
7 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 7 known security problems on this page. Each one has a fixed version. Updating to version 1.5.19.2 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a shop manager account on your site could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.19.1
- Fixed in
- 1.5.19.2
- What to do
- If your site has an affected version, update Kadence WooCommerce Email Designer to version 1.5.19.2 or newer.
- Official ID
- CVE-2026-94677
- Report title
- Kadence WooCommerce Email Designer <= 1.5.19.1 - Authenticated (Shop Manager+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
A stranger could take over your site as an admin
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.19
- Fixed in
- 1.5.19.1
- What to do
- If your site has an affected version, update Kadence WooCommerce Email Designer to version 1.5.19.1 or newer.
- Official ID
- CVE-2026-28005
- Report title
- Kadence WooCommerce Email Designer <= 1.5.19 - Unauthenticated Privilege Escalation
- First reported
- Sources
- Wordfence, seen
A stranger could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.17
- Fixed in
- 1.5.18
- What to do
- If your site has an affected version, update Kadence WooCommerce Email Designer to version 1.5.18 or newer.
- Official ID
- CVE-2025-13387
- Report title
- Kadence WooCommerce Email Designer <= 1.5.17 - Unauthenticated Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a shop manager account on your site could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.16
- Fixed in
- 1.5.17
- What to do
- If your site has an affected version, update Kadence WooCommerce Email Designer to version 1.5.17 or newer.
- Official ID
- CVE-2025-54697
- Report title
- Kadence WooCommerce Email Designer <= 1.5.16 - Authenticated (Shop Manager+) Arbitrary Options Update
- First reported
- Sources
- Wordfence, seen
Someone could run their own code on your site and take it over
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.14
- Fixed in
- 1.5.15
- What to do
- If your site has an affected version, update Kadence WooCommerce Email Designer to version 1.5.15 or newer.
- Official ID
- CVE-2025-39557
- Report title
- Kadence WooCommerce Email Designer <= 1.5.14 - Authenticated (Admin+) Arbitrary File Upload
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.11
- Fixed in
- 1.5.12
- What to do
- If your site has an affected version, update Kadence WooCommerce Email Designer to version 1.5.12 or newer.
- Official ID
- CVE-2023-47186
- Report title
- Kadence WooCommerce Email Designer <= 1.5.11 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.6
- Fixed in
- 1.5.7
- What to do
- If your site has an affected version, update Kadence WooCommerce Email Designer to version 1.5.7 or newer.
- Official ID
- CVE-2022-3335
- Report title
- Kadence WooCommerce Email Designer <= 1.5.6 - PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)