EN ES
Start free

Custom Block Builder – Lazy Blocks: known security problems

4 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 4 known security problems on this page. Each one has a fixed version. Updating to version 4.3.0 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone who already has an admin account could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 4.3.0
Fixed in
4.3.0
What to do
If your site has an affected version, update Custom Block Builder – Lazy Blocks to version 4.3.0 or newer.
Official ID
CVE-2026-8981
Report title
Custom Block Builder – Lazy Blocks < 4.3.0 - Authenticated (Administrator+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could run their own code on your site and take it over

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.2.0
Fixed in
4.2.1
What to do
If your site has an affected version, update Custom Block Builder – Lazy Blocks to version 4.2.1 or newer.
Official ID
CVE-2026-1560
Report title
Custom Block Builder – Lazy Blocks <= 4.2.0 - Authenticated (Contributor+) Remote Code Execution
First reported
Sources
This week

Someone could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.1.0
Fixed in
4.1.1
What to do
If your site has an affected version, update Custom Block Builder – Lazy Blocks to version 4.1.1 or newer.
Official ID
CVE-2025-58258
Report title
Lazy Blocks <= 4.1.0 - Missing Authorization
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.8.2
Fixed in
3.8.3
What to do
If your site has an affected version, update Custom Block Builder – Lazy Blocks to version 3.8.3 or newer.
Official ID
CVE-2024-12878
Report title
Custom Block Builder – Lazy Blocks <= 3.8.2 - Reflected Cross-Site Scripting
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)