EN ES
Start free

Loco Translate: known security problems

9 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 9 known security problems on this page. Each one has a fixed version. Updating to version 2.8.9 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 2.8.8)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.8.8
Fixed in
2.8.9
What to do
If your site has an affected version, update Loco Translate to version 2.8.9 or newer.
Official ID
CVE-2026-94239
Report title
Loco Translate <= 2.8.8 - Authenticated (Translator+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.8.8
Fixed in
2.8.9
What to do
If your site has an affected version, update Loco Translate to version 2.8.9 or newer.
Official ID
CVE-2026-94238
Report title
Loco Translate <= 2.8.8 - Authenticated (Translator+) Limited File Read
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 2.8.7)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.8.7
Fixed in
2.8.8
What to do
If your site has an affected version, update Loco Translate to version 2.8.8 or newer.
Official ID
CVE-2026-15066
Report title
Loco Translate <= 2.8.7 - Authenticated (Translator+) Stored Cross-Site Scripting via PO File Extracted Comments
First reported
Sources
This week

Someone could run their own code on your site and take it over (up to and including 2.8.5)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.8.5
Fixed in
2.8.6
What to do
If your site has an affected version, update Loco Translate to version 2.8.6 or newer.
Official ID
CVE-2026-15005
Report title
Loco Translate <= 2.8.5 - Cross-Site Request Forgery to Remote Code Execution via 'template' Parameter
First reported
Sources
This week

Someone could read or delete private files on your server

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.8.2
Fixed in
2.8.3
What to do
If your site has an affected version, update Loco Translate to version 2.8.3 or newer.
Official ID
CVE-2026-1921
Report title
Loco Translate <= 2.8.2 - Authenticated (Translator+) Path Traversal to Limited File Read via 'ref' Parameter
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 2.8.2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.8.2
Fixed in
2.8.3
What to do
If your site has an affected version, update Loco Translate to version 2.8.3 or newer.
Official ID
CVE-2026-4146
Report title
Loco Translate <= 2.8.2 - Reflected Cross-Site Scripting via 'update_href' Parameter
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.6.9
Fixed in
2.6.10
What to do
If your site has an affected version, update Loco Translate to version 2.6.10 or newer.
Official ID
CVE-2024-37236
Report title
Loco Translate <= 2.6.9 - Cross-Site Request Forgery
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (before 2.6.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 2.6.1
Fixed in
2.6.1
What to do
If your site has an affected version, update Loco Translate to version 2.6.1 or newer.
Official ID
CVE-2022-0765
Report title
Loco Translate <= 2.6.0 - Authenticated Stored Cross-Site Scripting
First reported
Sources
This week

Someone could run their own code on your site and take it over (before 2.5.4)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 2.5.4
Fixed in
2.5.4
What to do
If your site has an affected version, update Loco Translate to version 2.5.4 or newer.
Official ID
CVE-2021-24721
Report title
Loco Translate <= 2.5.3 - Authenticated PHP Code Injection
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)