EN ES
Start free

Login With Ajax: known security problems

8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 8 known security problems on this page. 6 of them have a fixed version. Updating to version 4.2 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Anyone with an account on your site, even a basic one could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.5.1
Fixed in
No fixed version yet
What to do
There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
Official ID
CVE-2026-82883
Report title
Login With Ajax – Fast Logins, 2FA, Redirects <= 4.5.1 - Authenticated (Customer+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.5.1
Fixed in
No fixed version yet
What to do
There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
Official ID
CVE-2026-66640
Report title
Login With Ajax – Fast Logins, 2FA, Redirects <= 4.5.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing (up to and including 4.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.1
Fixed in
4.2
What to do
If your site has an affected version, update Login With Ajax to version 4.2 or newer.
Official ID
CVE-2024-30546
Report title
Login With Ajax <= 4.1 - Cross-Site Request Forgery to Notice Dismissal
First reported
Sources
This week

Someone could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.1
Fixed in
4.2
What to do
If your site has an affected version, update Login With Ajax to version 4.2 or newer.
Official ID
CVE-2023-49859
Report title
Login With Ajax <= 4.1 - Missing Authorization
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 3.1.6)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.1.6
Fixed in
3.1.7
What to do
If your site has an affected version, update Login With Ajax to version 3.1.7 or newer.
Report title
Login With Ajax <= 3.1.6 - Cross-Site Scripting
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing (before 3.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 3.1
Fixed in
3.1
What to do
If your site has an affected version, update Login With Ajax to version 3.1 or newer.
Official ID
CVE-2013-2707
Report title
Login With Ajax < 3.1 - Cross-Site Request Forgery
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 3.0.4)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.0.4
Fixed in
3.0.4.1
What to do
If your site has an affected version, update Login With Ajax to version 3.0.4.1 or newer.
Official ID
CVE-2012-2759
Report title
Login With Ajax <= 3.0.4 - Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (before 3.0.4.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 3.0.4.1
Fixed in
3.0.5
What to do
If your site has an affected version, update Login With Ajax to version 3.0.5 or newer.
Official ID
CVE-2012-4283
Report title
Login With Ajax < 3.0.4.1 - Cross-Site Scripting
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)