EN ES
Start free

LWS Optimize: known security problems

5 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 5 known security problems on this page. Each one has a fixed version. Updating to version 4.1.2 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

A stranger could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.1.1
Fixed in
4.1.2
What to do
If your site has an affected version, update LWS Optimize to version 4.1.2 or newer.
Official ID
CVE-2026-16032
Report title
LWS Optimize <= 4.1.1 - Unauthenticated Stored Cross-Site Scripting
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (before 3.4)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 3.4
Fixed in
3.4
What to do
If your site has an affected version, update LWS Optimize to version 3.4 or newer.
Official ID
CVE-2026-16042
Report title
LWS Optimize – All-in-One Speed Booster & Cache Tools < 3.4 - Missing Authorization
First reported
Sources
This week

Someone with an editor account on your site could read or delete private files on your server

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.3.19
Fixed in
3.3.20
What to do
If your site has an affected version, update LWS Optimize to version 3.3.20 or newer.
Official ID
CVE-2026-12089
Report title
WS Optimize – All-in-One Speed Booster & Cache Tools <= 3.3.19 - Authenticated (Editor+) Arbitrary File Read
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.9.1
Fixed in
2.0
What to do
If your site has an affected version, update LWS Optimize to version 2.0 or newer.
Official ID
CVE-2024-30541
Report title
LWS Optimize <= 1.9.1 - Cross-Site Request Forgery
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (up to and including 1.5)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.5
Fixed in
1.6
What to do
If your site has an affected version, update LWS Optimize to version 1.6 or newer.
Report title
LWS Plugins <= (Various Versions) - Missing Authorization Checks
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)