MC4WP: Mailchimp for WordPress: known security problems
13 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 13 known security problems on this page. Each one has a fixed version. Updating to version 4.14.1 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could plant harmful code that runs for your visitors or admins (up to and including 4.14.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.14.0
- Fixed in
- 4.14.1
- What to do
- If your site has an affected version, update MC4WP: Mailchimp for WordPress to version 4.14.1 or newer.
- Official ID
- CVE-2026-87917
- Report title
- MC4WP: Mailchimp for WordPress <= 4.14.0 - Reflected Cross-Site Scripting via 'data' Dynamic Content Tag
- First reported
- Sources
- Wordfence, seen
Someone with an author account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.12.0
- Fixed in
- 4.12.1
- What to do
- If your site has an affected version, update MC4WP: Mailchimp for WordPress to version 4.12.1 or newer.
- Official ID
- CVE-2026-4561
- Report title
- MC4WP: Mailchimp for WordPress <= 4.12.0 - Authenticated (Author+) Stored Cross-Site Scripting via Form Response Messages
- First reported
- Sources
- Wordfence, seen
A stranger could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.11.1
- Fixed in
- 4.12.0
- What to do
- If your site has an affected version, update MC4WP: Mailchimp for WordPress to version 4.12.0 or newer.
- Official ID
- CVE-2026-1781
- Report title
- MC4WP: Mailchimp for WordPress <= 4.11.1 - Missing Authorization to Unauthenticated Arbitrary Subscription Deletion
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.9.16
- Fixed in
- 4.9.17
- What to do
- If your site has an affected version, update MC4WP: Mailchimp for WordPress to version 4.9.17 or newer.
- Official ID
- CVE-2024-8680
- Report title
- MailChimp for Wordpress <= 4.9.16 - Authenticated (Administrator+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (from 4.9.9 up to and including 4.9.16)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- From 4.9.9 up to and including 4.9.16
- Fixed in
- 4.9.17
- What to do
- If your site has an affected version, update MC4WP: Mailchimp for WordPress to version 4.9.17 or newer.
- Official ID
- CVE-2024-8850
- Report title
- MC4WP: Mailchimp for WordPress 4.9.9 - 4.9.16 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.9.9
- Fixed in
- 4.9.10
- What to do
- If your site has an affected version, update MC4WP: Mailchimp for WordPress to version 4.9.10 or newer.
- Official ID
- CVE-2023-51682
- Report title
- MC4WP <= 4.9.9 - Missing Authorization via listen
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 4.8.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.8.6
- Fixed in
- 4.8.7
- What to do
- If your site has an affected version, update MC4WP: Mailchimp for WordPress to version 4.8.7 or newer.
- Official ID
- CVE-2021-36833
- Report title
- MC4WP: Mailchimp for WordPress <= 4.8.6 - Authenticated (Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 4.8.7)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.8.7
- Fixed in
- 4.8.7
- What to do
- If your site has an affected version, update MC4WP: Mailchimp for WordPress to version 4.8.7 or newer.
- Report title
- MC4WP: Mailchimp for WordPress < 4.8.7 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.8.4
- Fixed in
- 4.8.5
- What to do
- If your site has an affected version, update MC4WP: Mailchimp for WordPress to version 4.8.5 or newer.
- Report title
- MC4WP: Mailchimp for WordPress <= 4.8.4 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could send your visitors from your site to a harmful site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.8.4
- Fixed in
- 4.8.5
- What to do
- If your site has an affected version, update MC4WP: Mailchimp for WordPress to version 4.8.5 or newer.
- Report title
- MC4WP: Mailchimp for WordPress <= 4.8.4 - Open Redirect
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 4.1.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.1.6
- Fixed in
- 4.1.7
- What to do
- If your site has an affected version, update MC4WP: Mailchimp for WordPress to version 4.1.7 or newer.
- Report title
- MC4WP: Mailchimp for WordPress <= 4.1.6 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 4.1.7)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.1.7
- Fixed in
- 4.1.8
- What to do
- If your site has an affected version, update MC4WP: Mailchimp for WordPress to version 4.1.8 or newer.
- Official ID
- CVE-2017-18577
- Report title
- Mailchimp For WP <= 4.1.7 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 4.0.11)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.0.11
- Fixed in
- 4.0.11
- What to do
- If your site has an affected version, update MC4WP: Mailchimp for WordPress to version 4.0.11 or newer.
- Official ID
- CVE-2016-10871
- Report title
- MailChimp for WordPress <= 4.0.10 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)