EN ES
Start free

MailOptin – Popup, Optin Forms & Email Newsletters for Mailchimp, HubSpot, AWeber Etc.: known security problems

8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 8 known security problems on this page. Each one has a fixed version. Updating to version 1.2.78.7 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

A stranger could take over your site as an admin (up to and including 1.2.78.6)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.2.78.6
Fixed in
1.2.78.7
What to do
If your site has an affected version, update MailOptin – Popup, Optin Forms & Email Newsletters for Mailchimp, HubSpot, AWeber Etc. to version 1.2.78.7 or newer.
Official ID
CVE-2026-109515
Report title
MailOptin <= 1.2.78.6 - Unauthenticated Privilege Escalation to 'form_custom_field_mappings' Parameter
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.2.78.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.2.78.0
Fixed in
1.2.78.1
What to do
If your site has an affected version, update MailOptin – Popup, Optin Forms & Email Newsletters for Mailchimp, HubSpot, AWeber Etc. to version 1.2.78.1 or newer.
Official ID
CVE-2026-66703
Report title
MailOptin – Popup, Optin Forms & Email Newsletters for Mailchimp, HubSpot, AWeber Etc. <= 1.2.78.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

A stranger could take over your site as an admin (up to and including 1.2.77.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.2.77.3
Fixed in
1.2.78.0
What to do
If your site has an affected version, update MailOptin – Popup, Optin Forms & Email Newsletters for Mailchimp, HubSpot, AWeber Etc. to version 1.2.78.0 or newer.
Official ID
CVE-2026-57813
Report title
MailOptin – Popup, Optin Forms & Email Newsletters for Mailchimp, HubSpot, AWeber Etc. <= 1.2.77.3 - Unauthenticated Privilege Escalation
First reported
Sources
This week

Someone who already has an admin account could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.2.75.0
Fixed in
1.2.75.1
What to do
If your site has an affected version, update MailOptin – Popup, Optin Forms & Email Newsletters for Mailchimp, HubSpot, AWeber Etc. to version 1.2.75.1 or newer.
Official ID
CVE-2025-58596
Report title
MailOptin <= 1.2.75.0 - Authenticated (Administrator+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.2.70.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.2.70.3
Fixed in
1.2.70.4
What to do
If your site has an affected version, update MailOptin – Popup, Optin Forms & Email Newsletters for Mailchimp, HubSpot, AWeber Etc. to version 1.2.70.4 or newer.
Official ID
CVE-2024-8628
Report title
Popup, Optin Form & Email Newsletters for Mailchimp, HubSpot, AWeber – MailOptin <= 1.2.70.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could use it to harm your site (from 1.2.54.0 up to and including 1.2.54.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • From 1.2.54.0 up to and including 1.2.54.0
Fixed in
1.2.54.1
What to do
If your site has an affected version, update MailOptin – Popup, Optin Forms & Email Newsletters for Mailchimp, HubSpot, AWeber Etc. to version 1.2.54.1 or newer.
Official ID
CVE-2023-23980
Report title
MailOptin <= 1.2.54.0 - Authenticated (Admin+) Cross Site Scripting
First reported
Sources
This week

Someone could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.2.49.0
Fixed in
1.2.50.0
What to do
If your site has an affected version, update MailOptin – Popup, Optin Forms & Email Newsletters for Mailchimp, HubSpot, AWeber Etc. to version 1.2.50.0 or newer.
Official ID
CVE-2022-36340
Report title
MailOptin <= 1.2.49.0 - Missing Authorization to Cache Deletion
First reported
Sources
This week

Someone could use it to harm your site (up to and including 1.2.35.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.2.35.1
Fixed in
1.2.35.2
What to do
If your site has an affected version, update MailOptin – Popup, Optin Forms & Email Newsletters for Mailchimp, HubSpot, AWeber Etc. to version 1.2.35.2 or newer.
Report title
Popup, Optin Form & Email Newsletters for Mailchimp, HubSpot, AWeber – MailOptin <= 1.2.35.1 - Authorization Bypass
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)