Meow Gallery: known security problems
11 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 11 known security problems on this page. Each one has a fixed version. Updating to version 5.5.5 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with an author account on your site could plant harmful code that runs for your visitors or admins (up to and including 5.5.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.5.1
- Fixed in
- 5.5.2
- What to do
- If your site has an affected version, update Meow Gallery to version 5.5.2 or newer.
- Official ID
- CVE-2026-9239
- Report title
- Meow Gallery <= 5.5.1 - Authenticated (Author+) Stored Cross-Site Scripting via Attachment Alt Text (aria-label attribute)
- First reported
- Sources
- Wordfence, seen
Someone with an author account on your site could do things on your site they should not be allowed to (up to and including 5.5.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.5.4
- Fixed in
- 5.5.5
- What to do
- If your site has an affected version, update Meow Gallery to version 5.5.5 or newer.
- Official ID
- CVE-2026-13747
- Report title
- Meow Gallery <= 5.5.4 - Missing Authorization to Authenticated (Author+) Information Disclosure via fetch_posts REST Endpoint
- First reported
- Sources
- Wordfence, seen
Someone with an author account on your site could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.5.4
- Fixed in
- 5.5.5
- What to do
- If your site has an affected version, update Meow Gallery to version 5.5.5 or newer.
- Official ID
- CVE-2026-92423
- Report title
- Meow Gallery <= 5.5.4 - Authenticated (Author+) Information Exposure
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.5.4
- Fixed in
- 5.5.5
- What to do
- If your site has an affected version, update Meow Gallery to version 5.5.5 or newer.
- Official ID
- CVE-2026-92422
- Report title
- Meow Gallery <= 5.5.4 - Unauthenticated Arbitrary Shortcode Execution
- First reported
- Sources
- Wordfence, seen
Someone with an author account on your site could plant harmful code that runs for your visitors or admins (up to and including 5.5.1) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.5.1
- Fixed in
- 5.5.2
- What to do
- If your site has an affected version, update Meow Gallery to version 5.5.2 or newer.
- Official ID
- CVE-2026-15386
- Report title
- Meow Gallery <= 5.5.1 - Authenticated (Author+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with an author account on your site could do things on your site they should not be allowed to (up to and including 5.4.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.4.4
- Fixed in
- 5.4.5
- What to do
- If your site has an affected version, update Meow Gallery to version 5.4.5 or newer.
- Official ID
- CVE-2026-1291
- Report title
- Meow Gallery <= 5.4.4 - Missing Authorization to Authenticated (Author+) Shortcode creation
- First reported
- Sources
- Wordfence, seen
Someone with an author account on your site could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.4.4
- Fixed in
- 5.4.5
- What to do
- If your site has an affected version, update Meow Gallery to version 5.4.5 or newer.
- Official ID
- CVE-2026-32418
- Report title
- Meow Gallery <= 5.4.4 - Authenticated (Author+) SQL Injection
- First reported
- Sources
- Wordfence, seen
Someone with an author account on your site could plant harmful code that runs for your visitors or admins (up to and including 5.2.7)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.2.7
- Fixed in
- 5.2.8
- What to do
- If your site has an affected version, update Meow Gallery to version 5.2.8 or newer.
- Official ID
- CVE-2025-47449
- Report title
- Meow Gallery <= 5.2.7 - Authenticated (Author+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.1.3
- Fixed in
- 5.1.4
- What to do
- If your site has an affected version, update Meow Gallery to version 5.1.4 or newer.
- Official ID
- CVE-2024-4386
- Report title
- Gallery Block (Meow Gallery) <= 5.1.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.1.9
- Fixed in
- 4.1.9
- What to do
- If your site has an affected version, update Meow Gallery to version 4.1.9 or newer.
- Official ID
- CVE-2021-24465
- Report title
- Meow Gallery (+ Gallery Block) <= 4.1.8 - SQL Injection
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.1.9
- Fixed in
- 4.2.0
- What to do
- If your site has an affected version, update Meow Gallery to version 4.2.0 or newer.
- Report title
- Meow Gallery (+ Gallery Block) <= 4.1.9 - Missing Authorization to Arbitrary Options Update
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)