Mesmerize Companion: known security problems
3 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 3 known security problems on this page. Each one has a fixed version. Updating to version 1.6.162 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Anyone with an account on your site, even a basic one could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.158
- Fixed in
- 1.6.162
- What to do
- If your site has an affected version, update Mesmerize Companion to version 1.6.162 or newer.
- Official ID
- CVE-2025-12027
- Report title
- Mesmerize Companion <= 1.6.158 - Missing Authorization Authenticated (Subscriber+) Settings Update
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.6.148)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.148
- Fixed in
- 1.6.149
- What to do
- If your site has an affected version, update Mesmerize Companion to version 1.6.149 or newer.
- Official ID
- CVE-2024-3494
- Report title
- Mesmerize Companion <= 1.6.148 - Authenticated (Contributor+) Stored Cross-Site Scripting via mesmerize_contact_form Shortcode
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.6.133)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.133
- Fixed in
- 1.6.135
- What to do
- If your site has an affected version, update Mesmerize Companion to version 1.6.135 or newer.
- Official ID
- CVE-2022-4481
- Report title
- Mesmerize Companion <= 1.6.133 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)