New User Approve: known security problems
13 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 13 known security problems on this page. Each one has a fixed version. Updating to version 3.2.10 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could use it to harm your site (from 3.1.0 up to and including 3.2.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- From 3.1.0 up to and including 3.2.9
- Fixed in
- 3.2.10
- What to do
- If your site has an affected version, update New User Approve to version 3.2.10 or newer.
- Official ID
- CVE-2026-83560
- Report title
- New User Approve 3.1.0 - 3.2.9 - Unauthenticated Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.2.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.8
- Fixed in
- 3.2.9
- What to do
- If your site has an affected version, update New User Approve to version 3.2.9 or newer.
- Official ID
- CVE-2026-28163
- Report title
- New User Approve <= 3.2.8 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.2.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.3
- Fixed in
- 3.2.4
- What to do
- If your site has an affected version, update New User Approve to version 3.2.4 or newer.
- Official ID
- CVE-2026-25390
- Report title
- New User Approve <= 3.2.3 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.2.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.0
- Fixed in
- 3.2.1
- What to do
- If your site has an affected version, update New User Approve to version 3.2.1 or newer.
- Official ID
- CVE-2025-69063
- Report title
- New User Approve <= 3.2.0 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
A stranger could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.2
- Fixed in
- 3.2.3
- What to do
- If your site has an affected version, update New User Approve to version 3.2.3 or newer.
- Official ID
- CVE-2026-0832
- Report title
- New User Approve <= 3.2.2 - Missing Authorization to Unauthenticated Arbitrary User Approval, Denial, and Information Disclosure
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site (up to and including 3.0.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.0.9
- Fixed in
- 3.1.0
- What to do
- If your site has an affected version, update New User Approve to version 3.1.0 or newer.
- Official ID
- CVE-2025-12770
- Report title
- New User Approve <= 3.0.9 - Unauthenticated Sensitive Information Disclosure via Type Juggling
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 3.2.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.3
- Fixed in
- 3.2.4
- What to do
- If your site has an affected version, update New User Approve to version 3.2.4 or newer.
- Official ID
- CVE-2025-63030
- Report title
- New User Approve <= 3.2.3 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 2.6.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.2
- Fixed in
- 2.6.4
- What to do
- If your site has an affected version, update New User Approve to version 2.6.4 or newer.
- Official ID
- CVE-2024-54323
- Report title
- New User Approve <= 2.6.2 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 2.5.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.5.1
- Fixed in
- 2.5.2
- What to do
- If your site has an affected version, update New User Approve to version 2.5.2 or newer.
- Official ID
- CVE-2023-50902
- Report title
- New User Approve <= 2.5.1 - Cross-Site Request Forgery via admin_notices
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.5.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.5.0
- Fixed in
- 2.5.1
- What to do
- If your site has an affected version, update New User Approve to version 2.5.1 or newer.
- Official ID
- CVE-2023-33999
- Report title
- Freemius SDK <= 2.5.9 - Reflected Cross-Site Scripting via fs_request_get
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 2.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4
- Fixed in
- 2.4.1
- What to do
- If your site has an affected version, update New User Approve to version 2.4.1 or newer.
- Official ID
- CVE-2022-1625
- Report title
- New User Approve <= 2.4 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4
- Fixed in
- 2.4.1
- What to do
- If your site has an affected version, update New User Approve to version 2.4.1 or newer.
- Report title
- New User Approve <= 2.4 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (before 2.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.1
- Fixed in
- 2.1
- What to do
- If your site has an affected version, update New User Approve to version 2.1 or newer.
- Official ID
- CVE-2022-4974
- Report title
- Freemius SDK <= 2.4.2 - Missing Authorization Checks
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)