MailerLite – Signup forms (official): known security problems
9 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 9 known security problems on this page. Each one has a fixed version. Updating to version 1.7.22 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.7.21
- Fixed in
- 1.7.22
- What to do
- If your site has an affected version, update MailerLite – Signup forms (official) to version 1.7.22 or newer.
- Official ID
- CVE-2026-3253
- Report title
- MailerLite – Signup forms (official) <= 1.7.21 - Missing Authorization to Authenticated (Contributor+) Form Creation and Deletion
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 1.7.18)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.7.18
- Fixed in
- 1.7.19
- What to do
- If your site has an affected version, update MailerLite – Signup forms (official) to version 1.7.19 or newer.
- Official ID
- CVE-2026-25420
- Report title
- MailerLite – Signup forms (official) <= 1.7.18 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.7.16
- Fixed in
- 1.7.17
- What to do
- If your site has an affected version, update MailerLite – Signup forms (official) to version 1.7.17 or newer.
- Official ID
- CVE-2025-13993
- Report title
- MailerLite – Signup forms (official) <= 1.7.16 - Authenticated (Administrator+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- From 1.5.0 up to and including 1.7.6
- Fixed in
- 1.7.7
- What to do
- If your site has an affected version, update MailerLite – Signup forms (official) to version 1.7.7 or newer.
- Official ID
- CVE-2024-1386
- Report title
- MailerLite – Signup forms (official) 1.5.0 - 1.7.6 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 1.7.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.7.6
- Fixed in
- 1.7.7
- What to do
- If your site has an affected version, update MailerLite – Signup forms (official) to version 1.7.7 or newer.
- Official ID
- CVE-2024-2797
- Report title
- MailerLite – Signup forms (official) <= 1.7.6 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 1.5.7)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.7
- Fixed in
- 1.5.8
- What to do
- If your site has an affected version, update MailerLite – Signup forms (official) to version 1.5.8 or newer.
- Official ID
- CVE-2022-33201
- Report title
- MailerLite – Signup forms (official) <= 1.5.7 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.3
- Fixed in
- 1.5.4
- What to do
- If your site has an affected version, update MailerLite – Signup forms (official) to version 1.5.4 or newer.
- Official ID
- CVE-2022-1604
- Report title
- MailerLite - Signup forms <= 1.5.3 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
A stranger could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 1.4.4
- Fixed in
- 1.4.4
- What to do
- If your site has an affected version, update MailerLite – Signup forms (official) to version 1.4.4 or newer.
- Report title
- MailerLite Signup Forms < 1.4.4 - Unauthenticated SQL Injection
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (before 1.4.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 1.4.5
- Fixed in
- 1.4.5
- What to do
- If your site has an affected version, update MailerLite – Signup forms (official) to version 1.4.5 or newer.
- Report title
- MailerLite – Signup forms <= 1.4.4 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)